Opened 11 years ago

Closed 11 years ago

#6234 closed defect (fixed)

UT failure: dojo/tests/_base/html.html failure on IE

Reported by: Douglas Hays Owned by: alex
Priority: high Milestone: 1.1
Component: Core Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description

Run dojo/tests/_base/html.html on IE.

_AssertFailure: [object Error]: assertEqual() failed: expected 1 but got 0 
[ Error: assertEqual() failed: expected 1 but got 0 ]
ERROR IN: attr_map(t)
FAILED test: attr_map
doh._failureCount: 1

The problem is that focus() on IE is asynchronous and the tests don't allow for that.

Attachments (1)

6234.patch (1.6 KB) - added by Douglas Hays 11 years ago.
fixes html.html w/o using Deferred+setTimeout+try/catch

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Douglas Hays

Attachment: 6234.patch added

fixes html.html w/o using Deferred+setTimeout+try/catch

comment:1 Changed 11 years ago by alex

the test in the patch is really brittle...it depends on order and shared globals...not a fan. I'll rework into something less brittle (probably using deferreds).

comment:2 Changed 11 years ago by alex

Resolution: fixed
Status: newclosed

(In [13207]) update to ensure that re-setting an event handler via dojo.attr() correctly handles dis-connection. misc size reductions. The case where dojo.connect() sets a handler and then dojo.attr() sets one will NOT be handled. Updates to tests. Fixes #6310. Fixes #6234. !strict

Note: See TracTickets for help on using tickets.