Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6225 closed defect (invalid)

dojo.data + grid editors does not work

Reported by: guest Owned by: benschell
Priority: blocker Milestone: 1.1
Component: DojoX Grid Version: 1.1b1
Keywords: grid data Cc: will@…
Blocked By: Blocking:

Description

When double clicking a cell to edit it, the editor does not display. This only happens when dojo.data is being used as the model.

Attachments (1)

6225.patch (1.0 KB) - added by benschell 12 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by Adam Peller

Owner: changed from sorvell to benschell

comment:2 Changed 12 years ago by benschell

Can you possibly give me a little more information about how to reproduce this bug? I edited one of the Grid + Dojo.data test files to have editors (it did not have them before) and, ignoring the IFRS error (since I'm attempting to edit the ID field in the store), the editors appear to work fine for me off of trunk. I'm attaching the patch to show how I'm testing, maybe you can point me in the right direction?

Changed 12 years ago by benschell

Attachment: 6225.patch added

comment:4 Changed 12 years ago by guest

I have a good feeling it has to do with the TextBox? editor... when I changed one of the rows in the test it broke:

	{ field: 4, width: 'auto', editor: dojox.grid.editors.TextBox},

comment:5 Changed 12 years ago by guest

Oh, I guess that editor was renamed to Input. doh.

comment:6 Changed 12 years ago by alex

Resolution: invalid
Status: newclosed

guess it's not a bug!

Thanks Ben!

comment:7 Changed 12 years ago by Adam Peller

is an exception raised on the console? If it's getting swallowed, I'd suggest that's a bug, though not a severe one.

comment:8 Changed 12 years ago by Adam Peller

hmm... ok so editor: is set to a value which is undefined, as opposed to editorClass which is quoted. This seems prone to errors such as this one. Anything we can do?

Note: See TracTickets for help on using tickets.