Opened 11 years ago

Closed 11 years ago

#6189 closed defect (fixed)

[patch] ComboBox/Editor: various height elements not working

Reported by: bill Owned by: haysmark
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 1.1b1
Keywords: Cc: nonken
Blocked By: Blocking:

Description (last modified by haysmark)

Not sure if this is a ComboBox problem or an Editor/FontPlugIn problem...

The larger items in the font-size drop down overlap each other

screenshot

Reproduced on FF2, IE7.

Attachments (3)

fontSize.gif (11.0 KB) - added by bill 11 years ago.
screenshot
fixedpopup.jpg (9.7 KB) - added by haysmark 11 years ago.
Same popup without global dojo.css li rules.
6189.patch (347 bytes) - added by haysmark 11 years ago.
Fixes #6189. Set the line-height on each of the options in ComboBoxMenu? to normal.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by bill

Attachment: fontSize.gif added

screenshot

comment:1 Changed 11 years ago by bill

Component: DijitDijit - LnF

comment:2 Changed 11 years ago by haysmark

Description: modified (diff)

It has to do with this code in dojo/resources/dojo.css:

ol li, ul li {
font-size:1em;
line-height:1.5em;
margin:0pt;
}

When I turn off font-size and line-height in Firebug I get a very different-looking menu.

Changed 11 years ago by haysmark

Attachment: fixedpopup.jpg added

Same popup without global dojo.css li rules.

comment:3 Changed 11 years ago by bill

Cc: nonken added
Milestone: 1.31.2

Ah thanks for finding this. Hmm, I'm not sure how we should address this. Options are:

  • modify dojo.css, either
    • removing that line-height rule since it will also mess up developers that setup a different font-size on their lists w/out adjusting line-height too.
    • Alternately, could it be changed to use margin or padding rather than line-height?
  • override that setting for ComboBox's drop down
  • override that setting just for the Editor
  • something else

Changed 11 years ago by haysmark

Attachment: 6189.patch added

Fixes #6189. Set the line-height on each of the options in ComboBoxMenu? to normal.

comment:4 Changed 11 years ago by haysmark

Status: newassigned
Summary: ComboBox/Editor: various height elements not working[patch] ComboBox/Editor: various height elements not working

IMO setting global styles in dojo.css seems pretty wonky to me, but here is a patch to fix ComboBoxMenu?.

comment:5 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [14295]) Fixes #6189: ComboBox/Editor?: various height elements not working

Note: See TracTickets for help on using tickets.