Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#6178 closed defect (fixed)

Button: mismatched fonts (IE)

Reported by: bill Owned by: nonken
Priority: high Milestone: 1.5
Component: Dijit - LnF Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by nonken)

On the mail demo the fonts for the buttons don't match:

screenshot

Reproduced on IE6, IE7.

Maybe related to #6150 although in this case my browser font settings are normal.

Attachments (1)

mismatchedFonts.gif (17.8 KB) - added by bill 11 years ago.
screenshot

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by bill

Attachment: mismatchedFonts.gif added

screenshot

comment:1 Changed 11 years ago by bill

Description: modified (diff)

comment:2 Changed 11 years ago by bill

Component: DijitDijit - LnF

comment:3 Changed 11 years ago by nonken

(In [15015]) Added additional testcase to test equal height of all buttons, refs #6178

comment:4 Changed 11 years ago by nonken

(In [15016]) fixed test, refs #6178

comment:5 Changed 11 years ago by nonken

Description: modified (diff)
Milestone: 1.21.3
Status: newassigned

I wasn't able to pinpoint the source of the issue but it seems to be table related. We also have general sizing issues with the ComboButton? which need to be addressed in a general button overhaul.

comment:6 Changed 10 years ago by bill

Milestone: 1.31.4

comment:7 Changed 10 years ago by bill

Milestone: 1.41.5

comment:8 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

I think the problem was because some of the Button widgets used <button> nodes and others didn't. In any case, now that we've converted all the Button widgets to just use <span> and <div> (except for ComboButton that's still a <table>), the fonts appear the same on IE6.

comment:9 Changed 8 years ago by bill

(In [23198]) Despite the checkin comment for [15016], seems like it broke things, by creating a tooltip for 1466 before 1466 exists. But I don't see a reason for that tooltip at all. Removing tooltip, fixing id's to be sequential, and adding a bunch of missing semicolons. Refs #6178.

Note: See TracTickets for help on using tickets.