Opened 12 years ago

Closed 11 years ago

#6173 closed defect (fixed)

ColorPalette: no hover/selection indication (Safari)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by nonken)

On test_ColorPalette.html on FF/IE, hovering over a cell or using the arrow keys to navigate between cells shows a black border around the cell... but for Safari nothing is shown. (At least for tundra theme.)

(For Safari arrows keys don't work, but still the hover thing should work)

Change History (6)

comment:1 Changed 12 years ago by bill

Component: DijitDijit - LnF

comment:2 Changed 11 years ago by nonken

Description: modified (diff)

This is because safari seems to have some issues with onfocus, the styles won't get set since the event doesn't fire

comment:3 Changed 11 years ago by nonken

ignore the last comment, the issue seems to have to do with when what event gets fired and how the widget reacts to it. It's not a CSS issue

comment:4 Changed 11 years ago by nonken

Owner: changed from nonken to dante

comment:5 Changed 11 years ago by bill

Owner: changed from dante to bill
Status: newassigned

I'll fix. I think the problem is that onMouseOver --> focus() event but that doesn't trigger the _onFocus() handler... that'll be fixed in a future version of Safari but we can workaround for now.

comment:6 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [14290]) Fixes #6173: no hover/selection indication on safari.

ColorPalette?'s design to have focus track mouse movement. combined with Safari's broken notification of focus events, was breaking highlighting on mouse movement. Work around the problem.

Could also have been fixed by making mouse hover independent of focus, although it's debatable whether or not that's a good idea.

!strict

Note: See TracTickets for help on using tickets.