Opened 12 years ago

Closed 11 years ago

#6170 closed defect (duplicate)

Dojo 1.0, Title pane, 2D charts, Tundra.css and IE6.0

Reported by: guest Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit Version: 1.0
Keywords: dojox, charting, titlepane, IE Cc: yazad3@…
Blocked By: Blocking:

Description (last modified by bill)

Hi,

I am trying to embed a simple 2d bar chart in a title pane. It works fine in FireFox? but it fails in IE6.0, a part of the defect is already reopened by me – ticket #5168 (axis misaligned). But there are some more issues. If you have set the TitlePaneâ?€™s open attribute to true, the chart is displayed, but if you collapse and re-expand the TitlePane?, the chart vanishes! If the TitlePane? is created with open=”false”, and the user expands the TitlePane?, the Chart’s AXIS is briefly displayed and the whole chart vanishes again! I am clueless; could someone shed some light on the issue? Apparently things seem to work fine in FireFox? 2.0.0.7. I have NOT tested on IE 7.0.

Regards, Yazad yazad3@…

Attachments (1)

simpleBarGraphTest.htm (1.6 KB) - added by guest 12 years ago.
This test case has got a case where a simple bar chart is placed within a TitlePane?, it works fine in FF2.0.0.7 but fails in IE6

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by Eugene Lazutkin

Component: ChartingDijit
Owner: changed from Eugene Lazutkin to bill

Layout widget help?

comment:2 Changed 12 years ago by Adam Peller

could you please attach test cases?

Changed 12 years ago by guest

Attachment: simpleBarGraphTest.htm added

This test case has got a case where a simple bar chart is placed within a TitlePane?, it works fine in FF2.0.0.7 but fails in IE6

comment:3 in reply to:  2 Changed 12 years ago by guest

Replying to peller:

could you please attach test cases?

I have attached simpleBarGraphTest.htm.

Regards, Yazad yazad3@…

comment:4 Changed 12 years ago by bill

Milestone: 1.3

I assume the problem is that you are building the chart into a <div style="display:none">, which (as per #5671) doesn't work, but I can look more closely after 1.1.

comment:5 in reply to:  4 Changed 12 years ago by guest

Replying to bill:

I assume the problem is that you are building the chart into a <div style="display:none">, which (as per #5671) doesn't work, but I can look more closely after 1.1.

No Bill, I am not using display: none.

I am using the code in the attachment... simpleBarGraphTest.htm

I am not sure if any of the CSS of title pane, tundra, use display:none!

Regards, Yazad yazad3@…

comment:6 Changed 11 years ago by bill

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Oh, I didn't mean that you were setting a div to style="display: none", I just meant that TitlePane does that internally.

Looks like this is a dup of #5671, or at least the same cause and the same solution.

Note: See TracTickets for help on using tickets.