Opened 12 years ago

Closed 11 years ago

Last modified 7 years ago

#6155 closed defect (fixed)

dragging on IE tends to select the underlying text

Reported by: bill Owned by: Eugene Lazutkin
Priority: high Milestone: 1.2.2
Component: DnD Version: 1.0
Keywords: Cc: Jared Jurkiewicz
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

See themeTester.html on IE6. On the DND tab, try to drag from one list to another. Chances are the underlying text (of the objects not being moved) will get selected and it's hard to drop.

unwanted selection

Problem happens when you quickly move the mouse after pressing the mouse button (perhaps moving the mouse before DnD code has started to execute). Not sure if it's feasible to fix but would definitely be nice.

BTW, I reproduced on IE6 on Windows, plus on parallels.

Attachments (1)

unwantedSelection.gif (13.5 KB) - added by bill 12 years ago.
unwanted selection

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by bill

Attachment: unwantedSelection.gif added

unwanted selection

comment:1 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.2
Status: newassigned

Dup of #4883, but reproduces the problem with unmodified test file. #4883 is closed in favor of this ticket.

The problem is unlikely to be solved cleanly. At this point it appears that IE6 may interpret onmousemove events with a pressed mouse button, as a text selection no matter what we do. To refresh the memory: onmousemove in uncancellable event. I observed similar effect under high load on FF2. If OS tries to load the handler in memory from disk while processing a mouse event, and fails to do so in some"reasonable time" (~1s), the event go to the browser, which starts the text selection process.

Probably the best we can do is to remove selection periodically during the move potentially causing a flicker.

comment:2 Changed 11 years ago by Douglas Hays

Cc: Jared Jurkiewicz added
Summary: dragging on IE6 tends to select the underlying textdragging on IE tends to select the underlying text

IBM #82133
Recreated using test_dnd.html and IE7

comment:3 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2future

Moving all open ticketd to the future.

comment:4 Changed 11 years ago by inow

I was able to fix the problem with selection by adding the following code at addOnLoad:

   dojo.connect(document.body, "onselectstart", function(event){
	if (dojo.dnd.manager().source) {
		dojo.stopEvent(event);
	}
   }); 

There could be some holes in it, but it's simple and seems to eliminate the selection issue.

comment:5 Changed 11 years ago by Eugene Lazutkin

Description: modified (diff)
Milestone: future1.2.1
Priority: normalhigh

comment:6 Changed 11 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

The trac is acting up and not registering changesets. This ticket was fixed.

comment:7 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2.11.2.2

comment:8 Changed 7 years ago by bill

Fixed in [15511] and [15664].

Note: See TracTickets for help on using tickets.