Opened 11 years ago

Closed 9 years ago

#6137 closed defect (fixed)

IE: Moving an element out of a surface causes shift of all groupped shapes

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.3
Component: DojoX GFX Version: 1.1b1
Keywords: group, move, shape Cc:
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

The problem is a differentce in behaviour of grouping under IE versus FireFox?. Apparently, you cannot move shapes out of a left top corner of a surface. So if a shape is moved higher then left top corner of the surface, then all other shapes that belongs to groups will be shifted, and the moved shape will be still visible. This is espesially annoying if you're dragging a shape out of the surface then all other shapes are moving & flipping.

To reproduce it please open the attached HTML in FireFox? first and then in IE.

Attached: test_group_bug.html - example FireFox_result.jpg - desired behavior IE_result.jpg - unexpected behavior

Attachments (3)

FireFox_result.jpg (15.7 KB) - added by guest 11 years ago.
IE_result.jpg (13.2 KB) - added by guest 11 years ago.
test_group_bug.html (4.6 KB) - added by guest 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by guest

Attachment: FireFox_result.jpg added

Changed 11 years ago by guest

Attachment: IE_result.jpg added

Changed 11 years ago by guest

Attachment: test_group_bug.html added

comment:1 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.11.1.1
Priority: highestnormal
severity: blockernormal
Status: newassigned

comment:2 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2future

Moving all open ticketd to the future.

comment:3 Changed 10 years ago by Eugene Lazutkin

Description: modified (diff)
Milestone: future1.3

Related to #7339.

comment:4 Changed 10 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

Fixed in #7339.

comment:5 Changed 10 years ago by Fredrik

Resolution: fixed
Status: closedreopened

How come this ticket is set to fixed? When trying out the attached test in IE it still fails using latest dojo 1.4.0 release.

I'm interested since this seems like the same VML problem reported about here http://bugs.dojotoolkit.org/ticket/9624, and to which I supplied another very similar test case.

Anyone got a clue about a possible fix? I should be able to do some hacking and testing if given some VML hints.

Fredrik

comment:6 Changed 9 years ago by Eugene Lazutkin

Resolution: fixed
Status: reopenedclosed

The problem in this ticket is not related to #9624. Use #9624 to track that problem.

Note: See TracTickets for help on using tickets.