Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#6125 closed defect (wontfix)

ComboBox: text following ComboBox appears before/behind it (IE7)

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Douglas Hays)

See test_ComboBox.html on IE7. Use the new zoom feature (Ctrl+) and then there are some ComboBox's with text following them, like this markup:

	<label for="datatest">US State test 2 (8pt font): </label>
	<input dojoType="dijit.form.ComboBox"
			value="California"
			class="medium"
			store="stateStore"
			searchAttr="name"
			style="width: 200px; font-size: 8pt;"
			name="state2"
			onChange="setVal2"
			id="datatest"
	>
	<span>Value: <input id="value2" disabled value="California"></span>
	<hr>

The "Value" string should clearly appear to the right of the combobox (or to the left on RTL systems). However, the text appears before (ie, to the left) and behind the ComboBox?:

image when font size increased

Attachments (2)

misplaced.gif (7.2 KB) - added by bill 12 years ago.
image when font size increased
zoom.html (235 bytes) - added by bill 12 years ago.
hmm, this trivial file also fails on IE7; if plain inputs don't work then can't expect ComboBox? to... hmm

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by bill

Attachment: misplaced.gif added

image when font size increased

comment:1 Changed 12 years ago by bill

Description: modified (diff)
Summary: ComboBox: when ComboBox is enlarged, text on right moves to left and behind (IE7)ComboBox: text following ComboBox appears before/behind it (IE7)

comment:2 Changed 12 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I ran test_ComboBox.html on IE7 and then increased the font size via
View->Text size->Largest and everything renders correctly.

comment:3 Changed 12 years ago by bill

Resolution: worksforme
Status: closedreopened

But it's failing for me, on two separate computers plus on parallels. Clearly there's a bug here (see the screenshot).

comment:4 Changed 12 years ago by guest

I can confirm this

comment:5 in reply to:  4 Changed 12 years ago by guest

When changing text size it works, but when you actually zoom in and out it shows up (Ctrl +/-)

comment:6 Changed 12 years ago by Douglas Hays

Description: modified (diff)

Changed 12 years ago by bill

Attachment: zoom.html added

hmm, this trivial file also fails on IE7; if plain inputs don't work then can't expect ComboBox? to... hmm

comment:7 Changed 12 years ago by Douglas Hays

I can fix test_combobox.html by adding

.dj_ie7 SPAN {
    zoom: 1;
}

but this doesn't address the bigger problem of requiring stylable tags with zoom:1 after input boxes.

comment:8 Changed 12 years ago by bill

Resolution: wontfix
Status: reopenedclosed

Yeah... I'm going to close this for now since the problem is bigger than just ComboBox? but rather affects IE in general, regardless of dojo (see attached zoom.html) ... and also since it's fixed in IE8. Surprising bug though.

comment:9 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.