Opened 11 years ago

Closed 11 years ago

#6124 closed defect (fixed)

year symbol corrupted up on builds

Reported by: bill Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit Version: 1.1b1
Keywords: Cc: Adam Peller, James Burke
Blocked By: Blocking:

Description (last modified by bill)

Something very strange w/the build. On the source themeTester the calendar shows up fine, w/correct kanji for month, days of week, and year. On the build themeTester on a Japanese OS, the calendar shows up fine *except* for the year sign (after 2007, 2008, 2009).

Reproduces on a local build.

Found out that dijit-all.js interns this code from date/locale.js:

year += "u5E74";

and converts it to:

year+="å¹´";

That looks fine... must be that we just need to specify the encoding of the dijit-all.js file (as UTF-8). as we include it into themeTester.html. I guess should be doing this everywhere.

Change History (3)

comment:1 Changed 11 years ago by bill

Component: BuildSystemDijit
Description: modified (diff)
Owner: changed from James Burke to bill
Status: newassigned
Summary: year signed messed up on japanese buildsyear symbol corrupted up on builds

comment:2 Changed 11 years ago by bill

Cc: Adam Peller James Burke added
Description: modified (diff)

comment:3 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [12978]) Fixes #6124: need to specify character set for dijit-all.js because it includes files with non-ascii characters (specifically, locale.js). Should probably be doing this for all of our <script> tags.

Note: See TracTickets for help on using tickets.