Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#6113 closed defect (fixed)

[patch][cla]Regression in dijit.form.Form / parsing

Reported by: dante Owned by: alex
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

as of the nightly: http://archive.dojotoolkit.org/dojo-2008-03-06/dojotoolkit/dijit/tests/form/Form.html

the Form unit test shows three failures in IE6

It fails when dojo.parser.parse is run over the content containing a <form dojoType="dijit.form.Form"> I was able to comment out the dojoType for the form, and the textboxs render and work properly, though the existence of a form causes the parser to die, completely.

Attachments (2)

6113_dojo.patch (1.4 KB) - added by Douglas Hays 12 years ago.
fix to dojo/tests/_base/html.html testcase
6113_dijit.patch (1.3 KB) - added by Douglas Hays 12 years ago.
fix to dijit/tests/form/form.html testcase

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by bill

Cc: Douglas Hays added
Owner: set to simonjb

Root cause is that dojo.attr(formNode, "onsubmit", myFunc); is failing on the delete node[name] (where name=="onsubmit"). So I guess this is a dojo.attr() problem. Not sure who to assign to, maybe simon?

comment:2 Changed 12 years ago by Douglas Hays

Cc: alex added; Douglas Hays removed

This is a regression that started failing with dojo core revision [12899].

comment:3 Changed 12 years ago by bill

Cc: alex removed
Owner: changed from simonjb to alex

comment:4 Changed 12 years ago by alex

Resolution: fixed
Status: newclosed

(In [13004]) update form processing to work on IE. Fixes #6113. Updates test page and docs in dijit.form.Form as well. !strict

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: closedreopened

Thanks for fixing the regression in dojo.attr(), but your change to Form.html breaks the unit test (at least on IE6). To reproduce: load Form.html in IE6 and look at firebug-lite console.

comment:6 Changed 12 years ago by bill

Also, the attribute map unit test is failing (at least on IE6).

comment:7 Changed 12 years ago by alex

thanks. will track it down.

Changed 12 years ago by Douglas Hays

Attachment: 6113_dojo.patch added

fix to dojo/tests/_base/html.html testcase

Changed 12 years ago by Douglas Hays

Attachment: 6113_dijit.patch added

fix to dijit/tests/form/form.html testcase

comment:8 Changed 12 years ago by Adam Peller

Summary: Regression in dijit.form.Form / parsing[patch][cla]Regression in dijit.form.Form / parsing

comment:9 Changed 12 years ago by alex

Resolution: fixed
Status: reopenedclosed

fixed in r13120

comment:10 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.