Opened 12 years ago

Closed 12 years ago

#6091 closed defect (fixed)

Regression in [12899]: Form test fails in IE7

Reported by: haysmark Owned by: alex
Priority: blocker Milestone: 1.1
Component: HTML Version: 1.0
Keywords: 4alex Cc:
Blocked By: Blocking:

Description

In [12899], load dijit/tests/form/Form.html in IE7. Dojo fails to initialize the widgets with this error log at the bottom:

dojo.addOnLoad callback failed: [object Error] [ Error: Object doesn't support this action ]
4 tests to run in 1 groups
------------------------------------------------------------
GROUP "dijit.form.Form" has 4 tests to run
_AssertFailure: [object Error]: assertEqual() failed: expected |{"foo":{"bar":{"baz":{"quux":"2007-12-30"}}},"available":{"from":"2005-01-02","to":"2006-01-02"},"plop":{"combo":"one"},"cb2":["2","3"],"r2":"2","ms1":["VA","WA"],"h1":"hidden","t1":"line 1
line 2","st1":"simple line 1
simple line 2","richtext":"<h1>original</h1><p>This is the default content</p>","filename":""}| but got |{}|
[ Error: assertEqual() failed: expected |{"foo":{"bar":{"baz":{"quux":"2007-12-30"}}},"available":{"from":"2005-01-02","to":"2006-01-02"},"plop":{"combo":"one"},"cb2":["2","3"],"r2":"2","ms1":["VA","WA"],"h1":"hidden","t1":"line 1
line 2","st1":"simple line 1
simple line 2","richtext":"
original
This is the default content

","filename":""}| but got |{}| ]
ERROR IN: function getValues(){ doh.is( dojo.toJson(original), dojo.toJson(dijit.byId("myForm").getValues()) ); }
FAILED test: getValues
_AssertFailure: [object Error]: assertEqual() failed: expected |{"foo":{"bar":{"baz":{"quux":"2005-01-01"}}},"available":{"from":"2005-11-02","to":"2006-11-02"},"plop":{"combo":"three"},"cb2":["4"],"r2":"1","ms1":["FL","CA"],"h1":"still hidden","t1":"new line 1
new line 2","st1":"new simple line 1
new simple line 2","richtext":"<h1>changed</h1><p>This is the changed content set by setValues</p>","filename":""}| but got |{}|
[ Error: assertEqual() failed: expected |{"foo":{"bar":{"baz":{"quux":"2005-01-01"}}},"available":{"from":"2005-11-02","to":"2006-11-02"},"plop":{"combo":"three"},"cb2":["4"],"r2":"1","ms1":["FL","CA"],"h1":"still hidden","t1":"new line 1
new line 2","st1":"new simple line 1
new simple line 2","richtext":"
changed
This is the changed content set by setValues

","filename":""}| but got |{}| ]
ERROR IN: function setValues(){ dijit.byId("myForm").setValues(changed); doh.is( dojo.toJson(changed), dojo.toJson(dijit.byId("myForm").getValues()) ); }
FAILED test: setValues
PASSED test: nameAttributeSurvived
_AssertFailure: [object Error]: assertEqual() failed: expected |{"foo":{"bar":{"baz":{"quux":"2007-12-30"}}},"available":{"from":"2005-01-02","to":"2006-01-02"},"plop":{"combo":"one"},"cb2":["2","3"],"r2":"2","ms1":["VA","WA"],"h1":"hidden","t1":"line 1
line 2","st1":"simple line 1
simple line 2","richtext":"<h1>changed</h1><p>This is the changed content set by setValues</p>","filename":""}| but got |{}|
[ Error: assertEqual() failed: expected |{"foo":{"bar":{"baz":{"quux":"2007-12-30"}}},"available":{"from":"2005-01-02","to":"2006-01-02"},"plop":{"combo":"one"},"cb2":["2","3"],"r2":"2","ms1":["VA","WA"],"h1":"hidden","t1":"line 1
line 2","st1":"simple line 1
simple line 2","richtext":"
changed
This is the changed content set by setValues

","filename":""}| but got |{}| ]
ERROR IN: function resetTest(){ dijit.byId("myForm").reset(); doh.is( dojo.toJson(reset), dojo.toJson(dijit.byId("myForm").getValues()) ); }
FAILED test: resetTest
doh._failureCount: 3
------------------------------------------------------------
| TEST SUMMARY:
------------------------------------------------------------
4 tests in 1 groups
0 errors
3 failuresTests:
tundra rtl a11y a11y+rtl 
soria rtl a11y a11y+rtl 
nihilo rtl a11y a11y+rtl 
jump to: themeTester 
or: tests folder 

Change History (3)

comment:1 Changed 12 years ago by alex

Resolution: fixed
Status: newclosed

(In [13120]) Fixes #6091. This bug had NOTHING to do with dojo.attr() and instead was caused by a change to test formatting (and a very brittle test setup...sigh). Furthermore, r12899 was not the cause. It's unclear why the initial filer didn't investigate the listed error messages further before marking this a blocker.

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: closedreopened

Failing again, this time for

and in editor.

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [13189]) Make comparison of Editor return code ignore irrelevant whitespace. Fixes #6091. Also added reset check, part of patch to #6299 (refs #6299)

Note: See TracTickets for help on using tickets.