Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#609 closed defect (fixed)

Tree is not shown at all in konqueror when controller is set

Reported by: wooyay Owned by: ilia
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

I use konqueror 3.5.2. Tree test 7 works perfectly. But when I add 'controller="treeController"' to the attributes of the tree widget div, the tree is not shown and I get DEBUG: fragment creation error: [TypeError: Undefined value]

Change History (8)

comment:1 Changed 14 years ago by mumme@…

This is actually caused by KJS not ordering properties in object in a for in iteration.

See #520 for more info

/ Fredrik

comment:2 Changed 14 years ago by Dustin Machi

Milestone: 0.3release0.4

comment:3 Changed 13 years ago by dylan

Owner: changed from anonymous to ilia

comment:4 Changed 13 years ago by dylan

Component: GeneralWidgets

comment:5 Changed 13 years ago by ilia

Is that for Tree or TreeV3 ? Still open ?

comment:6 Changed 13 years ago by mumme

It is a issue for TreeV3 for konqueror users pre 3.5.4, It isnt caused by TreeV3 at all. Its the dojo.widget.Parse assumtion that a iteration on a object will be ordered the same way they came in. The standard doesnt state that, but most browsers do it anyway. Konqueror 3.5.4 has native sorted objects iterations.

testing with konqueror, there are only a few tests that is broke: demo.html largedndmenu.html

TypeError?: Attempted to access 'listenTree' property on undefined object

(result of expression t.listenTree) menu1.html

rpc1.html

So you can probably close this bug, it isnt tree related in the first place.

/ Fredrik

comment:7 Changed 13 years ago by ilia

Resolution: fixed
Status: newclosed

comment:8 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.