Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6087 closed defect (fixed)

TextArea: does not display disabled state

Reported by: dante Owned by: bill
Priority: low Milestone: 1.2
Component: Dijit - LnF Version: 1.0
Keywords: Cc: nonken
Blocked By: Blocking:

Description (last modified by Douglas Hays)

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Textarea.html

In the test page, if you disable the Textarea via the button, the input stops, though the Textarea doesn't look disabled at all.

Probably affects tundra, soria and nihilo.

Change History (8)

comment:1 Changed 11 years ago by Douglas Hays

Component: DijitDijit - LnF
Description: modified (diff)

comment:2 Changed 11 years ago by bill

Owner: set to bill
Status: newassigned
Summary: Dijit Textarea does not display disabled stateTextArea: does not display disabled state

comment:3 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [13362]) CSS fixes for TextArea? and TextBox? disabled and focused modes:

  • make disabled TextBox? based widgets (like ComboBox?) have gray text, to disambiguate them from enabled states (fixes #6574).
  • make TextArea/SimpleTextArea? indicate focus with darker border, just like TextBox? based widgets (fixes #6470). Note that for TextArea? widget, _focused and _blurred where bad names for private methods, since they conflict w/the state variables used by FormWidget:setStateClass().

!strict

comment:4 Changed 11 years ago by bill

(In [13447]) Make themeTester.html have enabled and disabled versions of all the form widgets. Refs #6152, #6574, #6087

Also removed class="medium" affecting sizes on themeTester. Refs #6326.

And did some general cleanup/refactoring of tabs.

comment:5 Changed 11 years ago by alex

(In [13745]) fixing unclosed tag introduced in [13447]. Refs #6152, #6574, #6087

comment:6 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

Hmm, this is broken again.

comment:7 Changed 11 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [15035]) Fix text to be gray when disabled (again), regression from [14181], fixes #6087, refs #6651.

Also fixed some spacing in Textarea.js.

comment:8 Changed 11 years ago by Nathan Toone

(In [15088]) Refs #6087 - missed another reference to dijitTextAreaDisabled

Note: See TracTickets for help on using tickets.