Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6077 closed defect (duplicate)

"[Error: Unspecified error.]" in test_Editor.html on IE7

Reported by: simonjb Owned by: liucougar
Priority: high Milestone: 1.1
Component: Editor Version: 1.0
Keywords: Cc: alex, Adam Peller, becka11y, Joseph Scheuhammer
Blocked By: Blocking:

Description

To reproduce:

  • open dijit/tests/test_Editor.html in IE7
  • "[Error: Unspecified error.]" is logged to the Firebug Lite

I observed the behavior on XP with Dojo served up by Apache 2 on Windows.

I experimented a bit with the test file. The error goes away if the editor with id="thud" (created from a textarea) doesn't have a "paste" plugin. That is, if I add:

plugins="['paste']"

I see the error, but if I replace with:

plugins="[]"

it goes away.

Change History (11)

comment:1 Changed 11 years ago by dylan

Milestone: 1.11.2

mass move of editor issues to 1.2.

comment:2 Changed 11 years ago by dylan

Milestone: 1.21.1
Priority: normalhigh
severity: normalcritical

per peller, moving back to 1.1

comment:3 Changed 11 years ago by liucougar

Resolution: worksforme
Status: newclosed

can't seem to reproduce, may be fixed in #6069

comment:4 Changed 11 years ago by Adam Peller

no, this was definitely confirmed after [12870] landed. We checked with simonjb. According to him, it was critical that Windows XP be used for the server, which does seem a bit odd.

Simon, can you point at an example on a server somewhere and reopen if you're confident this is still a bug?

comment:5 Changed 11 years ago by Joseph Scheuhammer

Cc: becka11y added
Resolution: worksforme
Status: closedreopened

Reopening, as simonjb and I have replicated with rev [12905]. Also, becka11y has verified that she can replicate with a local Win XP server.

Simon, can you point at an example on a server somewhere...

http://142.150.154.170/dojo/dijit/tests/test_Editor.html

Note: the above host is a desktop used for development -- it will be rebooted frequently. We will try to keep it up as much as possible.

comment:6 Changed 11 years ago by Adam Peller

we should retest with Doug's patch for #5617

comment:7 Changed 11 years ago by Douglas Hays

I tested using patch #3 from #5617 and this problem appears to be fixed.

comment:8 in reply to:  6 Changed 11 years ago by Joseph Scheuhammer

Replying to peller:

we should retest with Doug's patch for #5617

I checked out, patched revision 13048, and tested it here. It works for me: http://142.150.154.170/dojo13048/dijit/tests/test_Editor.html

comment:9 Changed 11 years ago by Joseph Scheuhammer

Cc: Joseph Scheuhammer added

I tested the latest trunk (rev 13156 [Mar 20, 2008]) and it works for me.

comment:10 Changed 11 years ago by Douglas Hays

Resolution: duplicate
Status: reopenedclosed

dup of #5617

comment:11 Changed 11 years ago by Joseph Scheuhammer

As this bug is now closed, I will no longer insure that the example is served up by us (142.150.154.170).

Note: See TracTickets for help on using tickets.