Opened 11 years ago

Closed 11 years ago

#6069 closed defect (fixed)

Editor: JS error on IE when clicking text

Reported by: bill Owned by: sjmiles
Priority: high Milestone: 1.1
Component: Dijit Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description

On IE on test_Editor.html in the latest build, just click some text in the editor and get a JS error because the onMouseDown handler in registerWin() is called with evt==null.

Actually I'm really confused because IE shouldn't be using iframes for the editor to begin with.

Change History (4)

comment:1 Changed 11 years ago by Douglas Hays

Owner: set to Douglas Hays

comment:2 Changed 11 years ago by Douglas Hays

regression in [12848] to event.js

comment:3 Changed 11 years ago by Douglas Hays

Owner: changed from Douglas Hays to sjmiles
severity: normalblocker

comment:4 Changed 11 years ago by sjmiles

Resolution: fixed
Status: newclosed

(In [12870]) Must pass calling context on event handler through to event fixer to locate the correct currentTarget and window.event. Fixes #6069. Fixes #6050. !strict

Note: See TracTickets for help on using tickets.