Opened 12 years ago

Closed 12 years ago

#6057 closed defect (wontfix)

Editor: insert image dialog has no text input cursor (FF2)

Reported by: Douglas Hays Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit Version: 1.1b1
Keywords: Editor Cc: Adam Peller
Blocked By: Blocking:

Description

Run dijit/tests/test_Editor.html using Firefox2.0.0.12/WinXP.
Scroll down to the "Optional Toolbar Buttons" editor and click the "Create link" icon.
Click in either the URL or description textboxes and there's no cursor.
The cursor shows up using Firefox 3.0b3.

Change History (2)

comment:1 Changed 12 years ago by Douglas Hays

dijit/tests/test_TooltipDialog.html shows the input caret just fine, so it's just a problem with the Editor TooltipDialog?.

comment:2 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: FF2: editor insert image dialog has no text input cursorEditor: insert image dialog has no text input cursor (FF2)

I looked into this a little. It's got nothing to do with opacity (the TooltipDialog don't use opacity), but rather with the dialog appearing over the iframe for the Editor. If you scroll your viewport such that the TooltipDialog appears above the Toolbar rather than below it (and thus not over the iframe), the cursor appears fine.

No ideas on how to fix this and since the issue is resolved in FF3 just going to close as "wontfix".

Note that you can still type in URLs even if the cursor doesn't appear. Although it's probably confusing for people.

Note: See TracTickets for help on using tickets.