Opened 13 years ago

Closed 13 years ago

#603 closed defect (invalid)

sortable table

Reported by: Tiago Freitas Leal tfl netcabo pt Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.2
Keywords: sortable table Cc:
Blocked By: Blocking:

Description

1-Sorting doesn't take into account accented letters, cedilla, etc

2-Under IE the title row is over the scroll bar.

3-Under IE the light green mouse over isn't visible.

Change History (1)

comment:1 Changed 13 years ago by Tom Trenka

Resolution: invalid
Status: newclosed

Tiago,

Thanks for the input. I'll address your first point first, then the second two:

--- 1-Sorting doesn't take into account accented letters, cedilla, etc.

If you've defined the column as type String (the default), the sorting is done according to the internal JS engine of the page. In general (unless you set the character set of the page), that will be according to the default character encoding, and accented letters aren't usually included in the right order with that. Unfortunately that's not a bug with the SortableTable? as much as it is with localization and internationalization, which (in this case) is a browser-level bug.

--- 2-Under IE the title row is over the scroll bar. 3-Under IE the light green mouse over isn't visible.

The SortableTable? itself does not define any style information; it provides hooks for you to create your own CSS code. I think you're probably referring to the test page, which demonstrates a really ugly hack for getting a table to scroll in Internet Explorer...either way that's a test/demo and not a part of the widget itself.

Note: See TracTickets for help on using tickets.