Opened 12 years ago

Closed 7 years ago

Last modified 7 years ago

#5999 closed enhancement (fixed)

Bookmark handling

Reported by: guest Owned by: Ben Lowery
Priority: low Milestone: 1.8
Component: Core Version: 1.0
Keywords: needsreview Cc:
Blocked By: Blocking:

Description (last modified by dylan)

This ticket is related to the issue described in #907 Better bookmarks handling.

The problem is that DOJO does not allow handling of:

  1. A user enters a web page, and decide to bookmark this page with link: page.html#tab=main.
  1. The user enters another page within the same web application (some time in the future or right away). The recently entered page has the following link: page.html#tab=search. The user then chooses the bookmarked page - page.html#tab=main.

It is not possible to isolate this change in URL with current dojo.back behavior because only window.location.hash has changed. There is no way of knowing that the change in hash is being handled by dojo.back or not. DOJO should at least provide a means to detect this so that programmers can handle it when needed.

Change History (6)

comment:1 Changed 12 years ago by dylan

Milestone: 1.2

comment:2 Changed 12 years ago by dylan

Owner: changed from anonymous to Ben Lowery

comment:3 Changed 11 years ago by dylan

Description: modified (diff)
Milestone: 1.2future

Moving undo/back bugs to future until Ben or someone else has time to tackle them.

comment:4 Changed 8 years ago by ben hockey

Keywords: needsreview added
Priority: highlow

does dojo.hash cover this?

comment:5 Changed 7 years ago by dylan

Resolution: fixed
Status: newclosed

Solved with dojo/hash and dojo/router. Closing as fixed.

comment:6 Changed 7 years ago by bill

Milestone: future1.8
Note: See TracTickets for help on using tickets.