Opened 12 years ago

Closed 11 years ago

#5994 closed defect (wontfix)

BorderContainer: nested border container test has unwanted scroll bars

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

In the test_BorderContainer_nested.html test, there's a scroll bar on the inner BorderContainer. Shouldn't be there.

Tested on FF3/mac.

Change History (10)

comment:1 Changed 12 years ago by Adam Peller

yeah, I suspect it's still some issues with borderbox measurements I'm not doing everywhere, since the border here throws off the pane by a couple of pixels. Could this be a 1.2 candidate?

comment:2 Changed 12 years ago by Adam Peller

possible dup of #5895

comment:3 Changed 12 years ago by Adam Peller

Milestone: 1.11.2

comment:4 Changed 11 years ago by Adam Peller

Description: modified (diff)
Milestone: 1.2future

comment:5 Changed 11 years ago by Adam Peller

actually, I can't reproduce this anymore, not even on 1.1.1. Can you, Bill? We're clearly running a different version of FF3 than we were back then. Don't know if that's a factor. 1.1.1 looks okay, and now I get the phantom scrollbar, which I think is covered under a different ticket.

comment:6 Changed 11 years ago by bill

Milestone: future1.2
Resolution: fixed
Status: newclosed

Yah, looks OK to me, I don't even see a phantom scroll bar. I'm marking as fixed although it's unclear if we are benefitting from our code changes or just updates to FF.

comment:7 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

Oh actually I'm seeing it on FF3/windows now. It's from the ContentPane surrounding the inner BorderContainer. The ContentPane has overflow:auto and I guess there's an off-by-one pixel calculation. Might as well just get rid of that intermediate ContentPane (it serves no purpose) and that should fix the test.

comment:8 Changed 11 years ago by Adam Peller

(In [14871]) remove unneeded ContentPane? around inner BorderContainer?. Refs #5994

comment:9 Changed 11 years ago by Adam Peller

So now I see the center pane of the inner bordercontainer (yellow) getting clipped with a phantom scrollbar and the wrong layout. This only seems to be a problem now that it's almost squeezed out of the layout... make a bit more room for the panel, and it looks fine. I guess this is a different bug.

comment:10 Changed 11 years ago by Adam Peller

Resolution: wontfix
Status: reopenedclosed

ok, so what I'm seeing now (you'd have to revert to [14871] for the old test_BorderContainer_full.html to see it) is that the center panel doesn't size small enough because it's smaller than the padding dimensions. I think that's just a CSS limitation; the pane can't physically size any smaller than the padding allows. wontfix.

Note: See TracTickets for help on using tickets.