Opened 11 years ago

Closed 11 years ago

#5977 closed defect (fixed)

[patch][cla] In IE, with RTL, header node scrolls when hovering over resize handles

Reported by: benschell Owned by: Bryan Forbes
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.0
Keywords: bidi Cc:
Blocked By: Blocking:

Description

In Internet Explorer, in RTL, hovering over a resize handle makes the header scroll to where the right-most edge is visible (rather than staying aligned).

Attachments (2)

5977.patch (642 bytes) - added by benschell 11 years ago.
5977demonstration.patch (785 bytes) - added by benschell 11 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by benschell

Status: newassigned

To clarify the original report, take the test_grid_rtl.html page as an example. Scroll the main scrollbox to the far left, then mouse over the header, specifically over the resize handle area. The header nodes will scroll to the far right so that the first column (Column 0 in the example page) will be in view.

With the fixes from #5263, this patch fixes the header scrolling issue. The offending problem is setting the cursor style. To correct, the attached patch saves the current scroll state, sets the cursor style, then re-setting the scroll state.

I researched capturing and squashing the scroll event that may have been fired as a result of the change in scroll state. However, IE does not fire a scroll event in this instance, so I'm not sure of another way to fix this issue.

This patch is based on the trunk version of Grid, so it may need to be regenerated if #5263 is accepted and checked in.

Changed 11 years ago by benschell

Attachment: 5977.patch added

comment:2 Changed 11 years ago by dylan

Milestone: 1.1
Summary: In IE, with RTL, header node scrolls when hovering over resize handles[patch][cla] In IE, with RTL, header node scrolls when hovering over resize handles
Version: 1.0

comment:3 Changed 11 years ago by Adam Peller

Keywords: bidi added

comment:4 Changed 11 years ago by Adam Peller

Ben, I'm not sure I understand this bug or how to reproduce it. Can you provide details? Hovering over the resizers in the header doesn't do anything unless you mouse-down, right? I do see some odd behavior when resizing headers in RTL, but this patch doesn't seem to change that.

comment:5 Changed 11 years ago by Adam Peller

hmm... ok, I see it in this one test file. Is that because of the multi-line header? Even with the patch, there seems to be some flicker going on.

comment:6 Changed 11 years ago by benschell

Adam,

I've attached patch to demonstrate the same original behavior, even when the structure is simple (no subrows). Looking at the test_grid_rtl.html test page in IE, if you scroll the Grid to the left, then hover over the resize handles, the header row scrolls all the way to the right (so that Column 0 is visible again).

The flickering is due to the patch, but I don't know how to get around it. To fix the behavior, I stored the scroll state before applying the cursor style, then set it afterwards. This sometimes results in a flicker as the box jumps around. However, I've not found any other way to squash or trap that scroll event, so this is the best solution I've come up with.

Changed 11 years ago by benschell

Attachment: 5977demonstration.patch added

comment:7 Changed 11 years ago by bill

Milestone: 1.11.2

Move all milestone 1.1 tickets to 1.2, except for reopened tickets and tickets opened after 1.1RC1 was released.

comment:8 Changed 11 years ago by benschell

Owner: benschell deleted
Status: assignednew

This problem still very much exists in IE, at least according to the test page (http://archive.dojotoolkit.org/nightly/checkout/dojox/grid/tests/test_grid_rtl.html) and the description in the first comment. I've not done development on Grid since before the rewrite, so I have no idea if the patch attached is still applicable. I don't know who should own this ticket now as I'm not able to investigate this issue prior to 1.2.

comment:9 Changed 11 years ago by benschell

Owner: set to Bryan Forbes

comment:10 Changed 11 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

(In [14562]) fixes #5977 !strict

  • Applying patch from Ben Schell (benschell) to fix scrolling in IE on RTL grid header mouseover.
Note: See TracTickets for help on using tickets.