Opened 11 years ago

Closed 11 years ago

#5947 closed defect (duplicate)

copyTests flag not working in custom builds

Reported by: guest Owned by: anonymous
Priority: high Milestone:
Component: General Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

When I do a build, I get all the tests and demos in it, regardless what value I set copyTests to, or if I omit it completely. Do seem to do something because the total size differs a bit depending on the setting, but it never do what I expect it to do: create clean build without any demos and tests.

A normal build is approx 20Mb in size and after I have removed stuff manually it is 5Mb, so the difference is huge. Admittedly, I also remove the dojox/off section which is humongous. Maybe that should also be switchable?

A typical bat file of mine:

build.bat version=%VERSION% profileFile="%OLDDIR%mm_profile.js" localeList="en-gb,en-us,de-de,sv-se" action="clean,release" releaseName=%RELEASENAME%  releaseDir=%RELEASEDIR% copyTests="false" cssOptimize="comments" optimize="shrinksafe" 

Change History (1)

comment:1 Changed 11 years ago by James Burke

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #3622.

As for an option to remove specific modules, I think it is easier just to have your build script do a directory removal after the dojo build completes. That way you have more control.

Note: See TracTickets for help on using tickets.