Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#5936 closed defect (worksforme)

ComboBox broken at Rev 12589

Reported by: guest Owned by:
Priority: high Milestone:
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

ComboBox? templates that were working now throw:

dojo.hitch: scopeonkeypress? is null (scope="[Widget dijit.form.ComboBox?, dijit_form_ComboBox_0]")

Change History (4)

comment:1 Changed 11 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I'm not seeing any error with the standard tests/form/test_ComboBox.html test.
Please attach any specific testcases or instructions.
If you have a custom ComboBox? template, then you may have to make a slight modification:
dojoAttachEvent="onkeypress, onkeyup, onfocus, compositionend"
was changed to
dojoAttachEvent="onkeypress:_onKeyPress, onfocus:_update, compositionend"
to prevent collision with user-defined event handlers with the same names.

comment:2 in reply to:  1 Changed 11 years ago by guest

I see that the problem is that I have a ComboBox? embedded in one of the pages of a TabContainer? and TabController? has a templateString of:

templateString: "<div wairole='tablist' dojoAttachEvent='onkeypress:onkeypress'></div>",

Now that I sort of see what is going on, I can create a custom ComboBox? to fix it, but it might be nice to have it work OOTB inside a TabContainer?.

Thanks for your help.

-Al Replying to doughays:

I'm not seeing any error with the standard tests/form/test_ComboBox.html test.
Please attach any specific testcases or instructions.
If you have a custom ComboBox? template, then you may have to make a slight modification:
dojoAttachEvent="onkeypress, onkeyup, onfocus, compositionend"
was changed to
dojoAttachEvent="onkeypress:_onKeyPress, onfocus:_update, compositionend"
to prevent collision with user-defined event handlers with the same names.

comment:3 Changed 11 years ago by bill

Hmm, I don't understand what one thing has to do with another, especially since presumably your ComboBox is not inside the TabController, right? The TabController just has the buttons for switching between tabs.

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.