Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5921 closed defect (fixed)

IE: image dialog failures when selecting existing image

Reported by: Adam Peller Owned by: liucougar
Priority: high Milestone: 1.1
Component: Editor Version: 1.0
Keywords: insertimage Cc:
Blocked By: Blocking:

Description

Click on an image. Click the image toolbar button. An exception is thrown. The form is not populated correctly, and you cannot click off the dialog.

Attachments (1)

Picture 6.png (57.8 KB) - added by Adam Peller 11 years ago.
The insert image button can be seen on the toolbar here to the right of the font size dropdown

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Adam Peller

Owner: changed from Adam Peller to liucougar
Priority: normalhigh

So with the present code, Cougar points out that there is no getBookmark() method.

Trying to use Editor._getBookmark()/_moveToBookmark() instead failed. When inserting an image at a caret, the image would end up at the beginning of a document, and when trying to edit and existing image, Editor would try using a bookmark of [undefined] which eventually blew up also.

Cougar, can you take a look at this? Thanks.

comment:2 Changed 11 years ago by Adam Peller

Keywords: insertimage added

comment:3 Changed 11 years ago by Adam Peller

note: in Editor._moveToBookmark() I had to assign var bookmark = b for the case where the input is not an Array

Changed 11 years ago by Adam Peller

Attachment: Picture 6.png added

The insert image button can be seen on the toolbar here to the right of the font size dropdown

comment:4 Changed 11 years ago by liucougar

Status: newassigned

comment:5 Changed 11 years ago by liucougar

Resolution: fixed
Status: assignedclosed

(In [12763]) fixes #5921:

  • fix broken _moveToBookmark function in Editor
  • use _moveToBookmark and _getBookmark in LinkDialog? plugin
  • this issue is caused by the fact that dojo._toArray does not support converting an IE controlrange to an array, revert back to do it manually

comment:6 Changed 11 years ago by Adam Peller

(In [12769]) A few reductions. Refs #5921

Note: See TracTickets for help on using tickets.