Opened 12 years ago

Closed 12 years ago

#5920 closed defect (duplicate)

"esc" doesn't always close tooltipdialogs in editor

Reported by: Adam Peller Owned by: Douglas Hays
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

In Safari, escape works if you're in a text field, but doesn't work if you click on the dialog area. In IE6, escape doesn't seem to work at all. Works fine in FF and IE7

Change History (16)

comment:1 Changed 12 years ago by Adam Peller

Description: modified (diff)

comment:2 Changed 12 years ago by Douglas Hays

Cc: Douglas Hays added

comment:3 Changed 12 years ago by Douglas Hays

Using dijit/tests/test_Dialog.html with IE6, click to open the first dialog.
Click in a dialog textbox, and press Esc. My entire IE6 browser window closes.
Try again but this time click on the dialog (free space around the textboxes) and not a textbox directly and press Esc. The dialog closes perfectly.
The browser-terminating problem is 100% recreatable. I'm not seeing any problem with Esc pressed in a dialog from the editor toolbar (current 1.1 trunk).

Since Safari cannot get focus on a div, it'll be more difficult to grab keys from the document and apply them to the dialog popup.

comment:4 Changed 12 years ago by davidb

Can we capture ESC in a textbox handler?

comment:5 Changed 12 years ago by Douglas Hays

Esc closes the dialog in Safari if in a textbox but not if the Dialog is clicked. I couldn't find any editor-initiated dialogs in Safari to test.

comment:6 in reply to:  4 Changed 12 years ago by davidb

Replying to davidb:

Can we capture ESC in a textbox handler?

Ignore this comment. I had the issue confused.

comment:7 Changed 12 years ago by Douglas Hays

for IE6 running test_TooltipDialog.html (first tooltip dialog popped up), ESC won't do anything with focus in a datetextbox or a timetextbox.

comment:8 Changed 12 years ago by Douglas Hays

Component: EditorDijit

comment:9 Changed 12 years ago by davidb

Status: newassigned

Tested IE6 (on XP) and can't recreate this bug.

comment:10 Changed 12 years ago by davidb

Resolution: worksforme
Status: assignedclosed

I can't (nor can Bill) recreate the safari issue either.

comment:11 in reply to:  3 Changed 12 years ago by davidb

Priority: normalhigh

Replying to doughays:

Using dijit/tests/test_Dialog.html with IE6, click to open the first dialog.
Click in a dialog textbox, and press Esc. My entire IE6 browser window closes.
Try again but this time click on the dialog (free space around the textboxes) and not a textbox directly and press Esc. The dialog closes perfectly.
The browser-terminating problem is 100% recreatable. I'm not seeing any problem with Esc pressed in a dialog from the editor toolbar (current 1.1 trunk).

Since Safari cannot get focus on a div, it'll be more difficult to grab keys from the document and apply them to the dialog popup.

Ugh. Okay sorry Doug your comment is confirmed and recreatable. The IE6 problem is a high priority.

comment:12 Changed 12 years ago by davidb

Resolution: worksforme
Status: closedreopened

comment:13 Changed 12 years ago by Douglas Hays

Cc: Douglas Hays removed
Owner: changed from davidb to Douglas Hays
Status: reopenednew

comment:14 Changed 12 years ago by davidb

Okay the remaining issue on this bug is a Safari issue:

Confirmed using Safari 3.0.4 1) Open test_Dialog.html 2) Click Show Dialog 3) Clicking whitespace in dialog (so that focus is not on a field) 4) press ESC

Expected: Dialog should close Actual: nothing.

Possibly related bug captured on new ticket:6182

comment:15 Changed 12 years ago by davidb

Doug, I recommend lowering the priority since it is an unusual edge case and Safari only. That is assuming you can't recreate the nastier IE6 issue reported either.

comment:16 Changed 12 years ago by Douglas Hays

Resolution: duplicate
Status: newclosed

Dup of #6182 and #6184.

Note: See TracTickets for help on using tickets.