Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#5892 closed defect (fixed)

IE: Cannot input some Polish characters in editor

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 1.3.1
Component: Editor Version: 1.0
Keywords: Cc: liucougar, hwcdl@…, alex
Blocked By: Blocking:

Description (last modified by Adam Peller)

seen on IE6/7. works fine in FF

Attachments (4)

editor-polish-input.patch (2.0 KB) - added by Adam Peller 12 years ago.
patch from Evan Huang (IBM, CCLA)
editor-polish-input.2.patch (1.6 KB) - added by Adam Peller 12 years ago.
revised patch from Evan
ime.patch (878 bytes) - added by Adam Peller 12 years ago.
a follow-up patch from Evan
ime-RichText.js (915 bytes) - added by Adam Peller 12 years ago.
a more generic patch to RichText?.js from Mehmet Akin (IBM)

Download all attachments as: .zip

Change History (18)

comment:1 Changed 12 years ago by Adam Peller

could this be related to #4743?

comment:2 Changed 12 years ago by Adam Peller

Description: modified (diff)
Summary: IE6: Cannot input some Polish characters in editorIE: Cannot input some Polish characters in editor

comment:3 Changed 12 years ago by Adam Peller

to reproduce: add Polish language and Programmer keyboard. Then when pressing RIGHT ALT + a, you'll input "*", and when pressing RIGHT ALT + z, you'll input "*"

Changed 12 years ago by Adam Peller

Attachment: editor-polish-input.patch added

patch from Evan Huang (IBM, CCLA)

Changed 12 years ago by Adam Peller

Attachment: editor-polish-input.2.patch added

revised patch from Evan

comment:4 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [12549]) Special handling for right alt key used for Polish input. Fixes #5892. Thanks, Evan!

Changed 12 years ago by Adam Peller

Attachment: ime.patch added

a follow-up patch from Evan

comment:5 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

Changed 12 years ago by Adam Peller

Attachment: ime-RichText.js added

a more generic patch to RichText?.js from Mehmet Akin (IBM)

comment:6 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

(In [13080]) One more tweak to the Polish IME problem. Fixes #5892

comment:7 Changed 11 years ago by Mariusz Jakubowski

Resolution: fixed
Status: closedreopened

this bug reappears in dojo 1.3 I have tested it on IE 6/7: right alt + a - selects all text right alt + s - produces a javascript error right alt + z - works

comment:8 Changed 11 years ago by Adam Peller

Milestone: 1.11.3.1

comment:9 Changed 11 years ago by Adam Peller

Can you provide the text you saw from the Javascript error?

comment:10 Changed 11 years ago by Mariusz Jakubowski

The error is Object doesn't support this property or method
RichText?.js [187] this.save(true)
RichText?.js [920] if(!h.handler.apply(this, args))
A handler is invoked like CTRL+a or CTRL+s was being pressed. I have checked the patches included and I think someone removed the fix in the current version. I think you have to check if alt is not pressed when ctrl is pressed.
I have modified the if in the 919 line (based on attached patches) to
if((!!h.shift == !!e.shiftKey)&&(!!h.ctrl == !!e.ctrlKey && !e.altKey)){
It works for me but I'm not sure if this is correct.

comment:11 Changed 11 years ago by Adam Peller

Cc: alex added

Apparently broken by [13373]

comment:12 Changed 11 years ago by Adam Peller

fix applied to trunk in [17346]. Thanks, Mariusz, for reporting this regression. Could you please test the latest trunk build and let me know if it looks ok to you? I moved the !e.altKey test outside the loop.

comment:13 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

(In [17348]) Checks 'alt' key when looking for a key handler match. Fixes Polish IME regression on 1.2 and 1.3 branches. Thanks, Mariusz Jakubowski. Fixes #5892

comment:14 Changed 10 years ago by Mariusz Jakubowski

Works great! Tested on IE6/IE7. Thanks.

Note: See TracTickets for help on using tickets.