Opened 12 years ago

Closed 11 years ago

#5863 closed defect (worksforme)

BiDi support by Grid Widget

Reported by: guest Owned by: sorvell
Priority: high Milestone: 1.1
Component: DojoX Grid Version: 1.0
Keywords: bidi Cc: junlcdl@…
Blocked By: Blocking:

Description (last modified by Adam Peller)

I wrote some codes like this:

<html>
<head>
  <title>Test dojox.Grid Basic</title>
  <script type="text/javascript">
   dojo.addOnLoad(function(){
	data = [ [ "normal", false, "new", 'But are not followed by two   
                   hexadecimal', 29.91, 10, false ],[ "important", 
                   false, "new", 'Because a % sign always indicates', 9.33, -5, 
                   false ],[ "important", false, "read", 'Signs can be selectively', 
                   19.34, 0, true ],[ "note", false, "read", 'However the reserved 
                   characters', 15.63, 0, true ],[ "normal", false, "replied", 'It 
                   is therefore necessary', 24.22, 5.50, true ],[ "important", 
                   false, "replied", 'To problems of corruption by', 9.12, -3, 
                   true ],[ "note", false, "replied", 'Which would simply be awkward
                   in', 12.15, -4, false ]];
	var model = new dojox.grid.data.table(null, data);
	var view = {
		    noscroll: true,	
		    cells : [[
			{ name: "1", width:"10em", noresize:true},		
			{ name: "2", width:"18em"},
			{ name: "3", width:"15em", noresize:true},
			{ name: "4", width: "33%", noresize:true}, 
			{ name: "5", width: "33%", noresize:true}, 
			{ name: "6", width: "10em", noresize:true}, 
			{ name: "7", width: "10em", noresize:true},
		    ]]
		    }
	var layout = [view];
	var grid = new dojox.Grid({
			"id": "grid",
			"model": model,
			"structure": layout,
			"autoHeight": "true"
		});
	dojo.byId("table").appendChild(grid.domNode);
	grid.render();
	});
</script>
</head>

<body>
<div id="table" style="direction: rtl;"></div>
</body>
</html>

I want to resize columns by only dragging the right of column "2", but the problem is that I can still resize columns by dragging the right side of column "4".

Change History (3)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralDojox
Description: modified (diff)
Keywords: bidi added
Milestone: 1.0.31.1
Owner: changed from anonymous to Adam Peller

Grid was not BiDi? ready in 1.0. You may want to check the trunk and also compare against existing defect #5263

Also, in the future, please attach code instead of inlining it. Thanks.

comment:2 Changed 12 years ago by Adam Peller

Component: DojoxDojoX Grid
Owner: changed from Adam Peller to sorvell

comment:3 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

note: you must declare dir=rtl on the HTML or BODY element to set direction for the whole page. Dojo doesn't support flipping individual elements or widgets.

Note: See TracTickets for help on using tickets.