Opened 12 years ago

Closed 10 years ago

#5856 closed defect (wontfix)

themeTester.html reload slows down on IE6

Reported by: bill Owned by:
Priority: high Milestone: future
Component: Dijit Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by dylan)

themeTester.html prints "Total parse time" to the console. On IE6 (WinXP on parallels on my machine running against source tree), the time goes from 10s, 15s, 20s, etc. each time reloaded. This is a regression from 1.0 where it went 9s, 12s, 16s.

No idea where the problem is, or even whether is dojo core or dijit, but marking as dijit.

Change History (4)

comment:1 Changed 11 years ago by dylan

Description: modified (diff)

I'm not sure we can fix this... it's slower because the theme tester does more. As far as why it's slower between iterations, it's a test page, so we're probably not doing enough to clean-up against memory leaks.

comment:2 Changed 11 years ago by bill

Milestone: 1.21.4

I don't think so. I tried the 1.0.2 themeTester.html against both codebases (had to include tundra.css and add class="tundra" to body tag), and it was 2.8s vs. 3.6s (on a real WinXP machine not parallels)... but also the times vary a lot so it's hard to get an accurate reading for how things have changed.

In any case, won't have time to look at this for 1.2...

comment:3 Changed 11 years ago by bill

Milestone: 1.4future

comment:4 Changed 10 years ago by bill

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.