Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#5854 closed enhancement (fixed)

[patch][cla]Add option in dijit.form.DropDownButton to open dropDown above and not only below

Reported by: Alessandro Ferrari Owned by: haysmark
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Attached patch add option in dijit.form.DropDownButton? to open dropDown above and not only below, but arrow should be reversed in "above" case and this isn't in the patch.

Attachments (3)

DropDownButtonCanOpenAbove.patch (1.4 KB) - added by guest 12 years ago.
Provided by Alessandro Ferrari
5854.patch (9.2 KB) - added by haysmark 10 years ago.
Refs #5854. Added position attribute to DropDownButton?. Refactor popup positioning code in Tooltip to dijit.getPopupAroundAlignment(). Removed TODO in DropDownButton? by adding call to dijit.getPopupAroundAlignment().
5854.2.patch (5.5 KB) - added by haysmark 10 years ago.
Refs #5854. Added position attribute to _hasDropDown. Refactor popup positioning code in Tooltip to dijit.getPopupAroundAlignment(). Removed TODO in _hasDropDown by adding call to dijit.getPopupAroundAlignment().

Download all attachments as: .zip

Change History (16)

comment:1 Changed 12 years ago by Adam Peller

could you identify yourself please, and whether you've signed a CLA?

Changed 12 years ago by guest

Provided by Alessandro Ferrari

comment:2 in reply to:  1 Changed 12 years ago by guest

I'll sign and send CLA in next days.

comment:3 Changed 12 years ago by bill

Milestone: 1.2
Reporter: changed from guest to Alessandro Ferrari

Great, thanks.

comment:4 in reply to:  3 Changed 12 years ago by guest

CLA submitted and confirmed.

Sincerely,
Alessandro Ferrari

comment:5 Changed 12 years ago by Adam Peller

Summary: Add option in dijit.form.DropDownButton to open dropDown above and not only below[patch][cla]Add option in dijit.form.DropDownButton to open dropDown above and not only below

comment:6 Changed 11 years ago by Douglas Hays

Milestone: 1.21.3
Owner: set to haysmark

Deferring since the patch doesn't change the arrow direction.

comment:7 Changed 11 years ago by bill

Milestone: 1.31.4

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

Changed 10 years ago by haysmark

Attachment: 5854.patch added

Refs #5854. Added position attribute to DropDownButton?. Refactor popup positioning code in Tooltip to dijit.getPopupAroundAlignment(). Removed TODO in DropDownButton? by adding call to dijit.getPopupAroundAlignment().

Changed 10 years ago by haysmark

Attachment: 5854.2.patch added

Refs #5854. Added position attribute to _hasDropDown. Refactor popup positioning code in Tooltip to dijit.getPopupAroundAlignment(). Removed TODO in _hasDropDown by adding call to dijit.getPopupAroundAlignment().

comment:8 Changed 10 years ago by haysmark

All of the drop down code the original patch references has been refactored to _hasDropDown, I attached a patch for the refactor.

comment:9 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

(In [19513]) Add option for widgets with drop downs (in particular DropDownButton? and ComboButton?) to open dropDown above and not only below, or even to the left or right.

I'd still like to add CSS classes and icons to control which arrow icon shows up though. Fixes #5854 !strict

Patch from Mark Hays (IBM, CCLA on file)

comment:10 Changed 10 years ago by bill

(In [19517]) Use up/down/right/left arrow icon depending on where the drop down is set to appear. Refs #5854 !strict

comment:11 Changed 10 years ago by bill

(In [19518]) Rename position to dropDownPosition to be clearer (albeit more verbose). Refs #5854 !strict

comment:12 Changed 9 years ago by bill

(In [21663]) Remove duplicated function definition from [19513], refs #5854, #10873.

comment:13 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.