Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#584 closed defect (wontfix)

problem generating compress dojo.js

Reported by: pass.travis@… Owned by: alex
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

when i run: ant -Dprofile=everything clean release

I get a dojo.js that looks like:

/*

Copyright (c) 2004-2005, The Dojo Foundation All Rights Reserved.

Licensed under the Academic Free License version 2.1 or above OR the modified BSD license. For more information on Dojo licensing, see:

http://dojotoolkit.org/community/licensing.shtml

*/

/*

This is a compiled version of Dojo, built for deployment and not for development. To get an editable version, please visit:

http://dojotoolkit.org

for documentation and information on getting the source.

*/

Exception in thread "main" java.lang.ClassFormatError?: Invalid method Code length 72147 in class file org/mozilla/javascript/gen/c1

at java.lang.ClassLoader?.defineClass1(Native Method) at java.lang.ClassLoader?.defineClass(ClassLoader?.java:620) at java.lang.ClassLoader?.defineClass(ClassLoader?.java:465) at org.mozilla.javascript.DefiningClassLoader?.defineClass(DefiningClassLoader?.java:57) at org.mozilla.javascript.optimizer.Codegen.defineClass(Codegen.java:122) at org.mozilla.javascript.optimizer.Codegen.createScriptObject(Codegen.java:77) at org.mozilla.javascript.Context.compileImpl(Context.java:2265) at org.mozilla.javascript.Context.compileString(Context.java:1314) at org.mozilla.javascript.Context.compileString(Context.java:1303) at org.mozilla.javascript.tools.shell.Main.loadScriptFromSource(Main.java:487) at org.mozilla.javascript.tools.shell.Main.processFileSecure(Main.java:403) at org.mozilla.javascript.tools.shell.Main.processFile(Main.java:369) at org.mozilla.javascript.tools.shell.Main.processSource(Main.java:360) at org.mozilla.javascript.tools.shell.Main.processFiles(Main.java:153) at org.mozilla.javascript.tools.shell.Main$IProxy.run(Main.java:83) at org.mozilla.javascript.Context.call(Context.java:528) at org.mozilla.javascript.ContextFactory?.call(ContextFactory?.java:447) at org.mozilla.javascript.tools.shell.Main.exec(Main.java:136) at org.mozilla.javascript.tools.shell.Main.main(Main.java:114)

If I remove Tree from the profile below, it works. I don't think it is the Tree in particular, but the size and Tree simply push the size over some limit.

My environment is:

java: java version "1.5.0_06" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05) Java HotSpot?(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)

ant: 1.6.5

everything.profile.js: var dependencies = [

"dojo.lang", "dojo.html", "dojo.style", "dojo.fx.*", "dojo.event.*", "dojo.logging.*", "dojo.io.*", "dojo.io.IframeIO", "dojo.date", "dojo.string.*", "dojo.regex", "dojo.rpc.*", "dojo.xml.*", "dojo.storage.*", "dojo.crypto.*", "dojo.collections.*", "dojo.collections.ArrayList?", "dojo.collections.Collections", "dojo.collections.Queue", "dojo.collections.Stack", "dojo.graphics.*", "dojo.animation.*", "dojo.io.BrowserIO", "dojo.dnd.*", "dojo.widget.*", "dojo.math.*", "dojo.reflect.*", "dojo.uri.*", "dojo.widget.*", "dojo.widget.html.*", "dojo.widget.FloatingPane?", "dojo.widget.ContentPane?", "dojo.widget.ResizeHandle?", "dojo.widget.LayoutPane?", "dojo.widget.ContentPane?", "dojo.widget.LinkPane?", "dojo.widget.SplitPane?", "dojo.widget.ColorPalette?", "dojo.widget.TabPane?", "dojo.widget.ComboBox?", "dojo.widget.html.ComboBox?", "dojo.widget.DebugConsole?", "dojo.widget.Tree",

"dojo.widget.TreeNode?", "dojo.widget.TreeSelector?", "dojo.widget.TreeBasicControler?", "dojo.dnd.TreeDragAndDrop?",

"dojo.html.shadow"

];

load("getDependencyList.js");

Change History (7)

comment:1 Changed 14 years ago by pass.travis@…

The version I was working against was actually the nightly from 30 Mar 2006

comment:2 Changed 14 years ago by alex

Milestone: 0.3release
Owner: changed from anonymous to alex
Status: newassigned

comment:4 Changed 14 years ago by pass.travis@…

I have not...let me try.

That worked, after some experiments, it is the "-opt -1" that does the trick.

Is there any reason to not make "-opt -1" the default?

The option seems to turn off compilation, and performance does not seem to be an issue at this step in the build.

comment:5 Changed 14 years ago by alex

Resolution: wontfix
Status: assignedclosed

workaround is documented. Marking wontfix.

comment:6 Changed 13 years ago by jkuhnert

FYI, the -opt -1 option is in the default build now.

comment:7 Changed 12 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.