Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#5827 closed defect (duplicate)

Safari Detection Broken

Reported by: benschell Owned by: alex
Priority: high Milestone:
Component: General Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Due to the fix in r12330, Safari detection is broken. Specifically, dojo.isSafari is set to 2 on Firefox (rather than undefined, the previous behavior), despite the fact that it is (obviously) not Safari.

Examining the contents of r12330 and comparing to previous behavior, the problem is on line 96, where idx is not checked to be >= 0 (as it was previously).

Patch attached.

Attachments (1)

5827.patch (674 bytes) - added by benschell 12 years ago.
Fixes the aforementioned problem.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by benschell

Attachment: 5827.patch added

Fixes the aforementioned problem.

comment:1 Changed 12 years ago by bill

Owner: changed from anonymous to alex

comment:2 Changed 12 years ago by Adam Peller

Resolution: duplicate
Status: newclosed
I reopened #5575. Not sure the patch works, since the
operator can't operate on -1 the way you'd want it to.
Note: See TracTickets for help on using tickets.