Opened 11 years ago

Closed 11 years ago

#5756 closed defect (duplicate)

Form submit doesn't work after dojo.io.iframe.send

Reported by: guest Owned by: anonymous
Priority: high Milestone:
Component: General Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

I use the send function like this :

dojo.io.iframe.send({url: 'x.do?method=setVal,

form: document.forms[0], handleAs: "application/json",

...

The send function of dojo.io.iframe call _fireNextRequest. This function ends with the foolowing instruction :

fn.target = this._iframeName;

This means that the target of the form passed to the send() function is overwritten each time I call the send function.

The result is that any call to the submit function of the form will be redirected to the hidden IFrame.

Change History (1)

comment:1 Changed 11 years ago by James Burke

Resolution: duplicate
Status: newclosed

Duplicate of #5755

Note: See TracTickets for help on using tickets.