Opened 11 years ago

Closed 11 years ago

#5754 closed defect (worksforme)

CSS <body style="text-align:center"> kills Grid

Reported by: guest Owned by: Nathan Toone
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Nathan Toone)

Using Dojo version: dojo-2008-01-31

When using <body style="text-align:center"> in a page with a grid, the grid looks weird and does not display data.

Attachments (2)

QRStoreTest.pt (2.8 KB) - added by guest 11 years ago.
Test Template (HTML)
QRStoreTestScript.xpy (683 bytes) - added by guest 11 years ago.
Test Script

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by guest

Attachment: QRStoreTest.pt added

Test Template (HTML)

Changed 11 years ago by guest

Attachment: QRStoreTestScript.xpy added

Test Script

comment:1 in reply to:  description Changed 11 years ago by guest

Attached Files are to be used with Zope.

comment:2 Changed 11 years ago by Adam Peller

Milestone: 1.0.31.1

comment:3 Changed 11 years ago by sorvell

Milestone: 1.11.2

Cannot reproduce this bug with any of the standard grid tests.

Please include a test case that is self-contained and does not require Zope.

Is it possible the grid stylesheets are not being properly loaded?

Also, is the problem specific to a particular browser or platform?

Thanks.

comment:4 Changed 11 years ago by guest

You can recreate this by taking test_grid.html and wrapping the grid containing div in another div with align attribute set to "center". The issue really is, how do we center a grid. Perhaps there is another way.

comment:5 Changed 11 years ago by Bryan Forbes

Owner: changed from sorvell to Bryan Forbes

comment:6 Changed 11 years ago by Nathan Toone

Description: modified (diff)
Owner: changed from Bryan Forbes to Nathan Toone
Status: newassigned

comment:7 Changed 11 years ago by Nathan Toone

Resolution: worksforme
Status: assignedclosed

Can't reproduce this using DataGrid? - reopen with a new test case if you continue to see the issue

Note: See TracTickets for help on using tickets.