Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5752 closed defect (fixed)

[patch][ccla]TabContainer: display problem when set page "dir" attribute to "RTL" in IE7

Reported by: guest Owned by: Adam Peller
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: bidi Cc: hwcdl@…
Blocked By: Blocking:

Description

When I set page "dir" attribute to "RTL" and set tabPosition to "top" or "bottom", the size of ContentPane? was very small, when I set tabPosition to "left-h" or "right-h", the ContentPane? did not be shown at all. But when I resize the IE7 window after page loaded, the ContentPane? will become normal. I have imported tundra.css, tundra_rtl.css and dojo.css.

<body class="tundra" dir="rtl">
   <div id="mainTabContainer" dojoType="dijit.layout.TabContainer"
        style="width:500px;height:100px" tabPosition="right-h">
      <div id="LittleRed" dojoType="dijit.layout.ContentPane" title="Little Red Cap">
      Once upon a time there was a dear little girl who was loved by
      every one who looked at her, but most of all by her grandmother,
      and there was nothing that she would not have given to the child.
      </div>
      <div id="HanselGretel" dojoType="dijit.layout.ContentPane"
           title="Hansel and Gretel" closable="true" selected="true">
      Hard by a great forest dwelt a poor wood-cutter with his wife
      and his two children. The boy was called Hansel and the girl Gretel.
      He had little to bite and to break, and once when great dearth fell
      on the land, he could no longer procure even daily bread.
      </div>
      <div id="GreenTwigs" dojoType="dijit.layout.ContentPane"
             title="The Three Green Twigs">
      There was once upon a time a hermit who lived in a forest at the foot
      of a mountain, and passed his time in prayer and good works,
      and every evening he carried, to the glory of God, two pails of water
      up the mountain.
      </div>
</div>
</body>

Attachments (2)

tab.html (2.2 KB) - added by guest 12 years ago.
tabContainer display problem
TabContainer-5752-12734.patch (4.3 KB) - added by Adam Peller 11 years ago.
patch from Evan Huang (IBM, CCLA)

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by bill

Owner: set to Adam Peller
Summary: tabContainer display problem when set page "dir" attribute to "RTL" in IE7TabContainer: display problem when set page "dir" attribute to "RTL" in IE7

comment:2 Changed 12 years ago by Adam Peller

Cc: hwcdl@… added
Keywords: bidi added

comment:3 Changed 12 years ago by Adam Peller

I'm unable to reproduce the problem. Asking the reporter for more info, and an attachment. http://www.dojotoolkit.org/forum/dijit-dijit-0-9/dijit-support/tabcontainer-display-problem-when-set-page-dir-attribute-rtl-ie7

Changed 12 years ago by guest

Attachment: tab.html added

tabContainer display problem

comment:4 in reply to:  3 Changed 12 years ago by guest

Replying to peller: I have added an attachment for this problem.

comment:5 Changed 12 years ago by Adam Peller

Milestone: 1.1

Changed 11 years ago by Adam Peller

patch from Evan Huang (IBM, CCLA)

comment:6 Changed 11 years ago by Adam Peller

Summary: TabContainer: display problem when set page "dir" attribute to "RTL" in IE7[patch][ccla]TabContainer: display problem when set page "dir" attribute to "RTL" in IE7

comment:7 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [12792]) Fix bidi for TabContainer? vertical tabs. Thanks, Evan (IBM). Fixes #5752 !strict

comment:8 Changed 11 years ago by bill

(In [13898]) Remove redundant tests for left and right tabs. The label (text) in the left/right tab tests should be different lengths to test alignment etc., so I kept those tests and erased the others. Refs #5752.

Note: See TracTickets for help on using tickets.