Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5737 closed defect (fixed)

ContentPane inside BorderContainer does not display the scroll bars when overflow.

Reported by: guest Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

In FF dijit.layout.ContentPane? does not display the scrollbars when the content overflow. Even if overflow-y:scroll and overflo-x:scroll

On I.E 7 it seems to work as expected.

Example: dijit/tests/layout/test_BorderContainer.html (see the container including the: "main panel with a link". move the splitter to minimize and maximize the container.

Eduardo

Attachments (7)

ff2.gif (8.8 KB) - added by guest 11 years ago.
ie7.gif (9.0 KB) - added by guest 11 years ago.
ie7.2.gif (9.0 KB) - added by guest 11 years ago.
new-ie7.gif (13.7 KB) - added by guest 11 years ago.
bc_test.jpg (128.8 KB) - added by tk 11 years ago.
IE7 vista - tk
bc_test2.jpg (53.5 KB) - added by tk 11 years ago.
IE7 vista 2 - tk
newAndLastFF2.gif (5.6 KB) - added by guest 11 years ago.
see the container with "main panel with a link" -> No Vertical Scroll Bar

Download all attachments as: .zip

Change History (23)

comment:1 Changed 11 years ago by guest

Additional explanations:

Example: dijit/tests/layout/test_BorderContainer.html (see the container including the: "main panel with a link". move the splitter (y direccion) to minimize and maximize the container. In FF the text dissapears as the Container minimizes, on IE7 a "Y" scroll bar appears so even if the Container is small, it is possible to read the inside text by scrolling.

This Bug is critical, because it is impossible to use the Border container on FF when the inside information is larger than the physical dimensions of the container.

thanks !

Eduardo

comment:2 Changed 11 years ago by bill

Milestone: 1.1
Owner: set to Adam Peller
Priority: highestnormal
severity: criticalnormal

Hmm, I'm guessing that setting top/bottom/left/right on a <div> makes overflow break... does it happen on FF3 or just FF2?

comment:3 Changed 11 years ago by guest

I havn't FF3. I just testit with FF2.

If you cannot test this with FF3, please write me I will try to download and install it in a virtual machine.

thanks

Eduardo

comment:4 Changed 11 years ago by Adam Peller

Priority: normalhigh

comment:5 Changed 11 years ago by Adam Peller

same results on FF3... but themeTester manages to display scrollbars as needed for its content. what's the difference in these tests?

comment:6 Changed 11 years ago by bill

I can't reproduce it, but anyway you should check in firebug to see if that pane's computed style is marked as overflow: hidden, and if so, trace which rule is causing it.

comment:7 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

Eduardo, I saw this also, but it seems to be working as of last night's build. Not sure if the CSS reorg helped or if it was some other fix. If you still see a problem, please reopen. Thanks.

Changed 11 years ago by guest

Attachment: ff2.gif added

Changed 11 years ago by guest

Attachment: ie7.gif added

Changed 11 years ago by guest

Attachment: ie7.2.gif added

comment:8 Changed 11 years ago by guest

Resolution: worksforme
Status: closedreopened

See please the pictures I attached. I think that there is a problem there. I try any possible value in the css without success.

the test I am using is :

dijit/tests/layout/test_BorderContainer_complex.html

Please give a look again.

thanks very much !

Eduardo

comment:9 in reply to:  8 ; Changed 11 years ago by guest

Huy! I am working with the last build of 9-02-2008 I can see that in the 11-02-2008 version something changed. FF2 is displaying the scrollbars, but IE7 is completely missed.(see new picture) I am now ouside my place, please give me some hours to check this as needed, I will return to you, after a more detailed check.

Eduardo

Changed 11 years ago by guest

Attachment: new-ie7.gif added

comment:10 in reply to:  9 Changed 11 years ago by guest

Yep, now for sure.

The Firefox problem seems to be resolved. The IE7 (tested on several IE7 versions, patches, etc) seems to crash the widget (note, please that it is a different problem now)

What you see in the attached gif is the result of a crash. Even the FilteringSelect? or combo con not be opened. The problem may be easily replicated because I am using the test file from dojo last building web site with any IE7. http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/layout/test_BorderContainer.html

thanks for your efforts

Eduardo

comment:11 Changed 11 years ago by bill

Resolution: fixed
Status: reopenedclosed

Hmm, I see that it was failing for you but it's working for both me and sfoster now. I even tried on two machines (one was parallels on the mac, but the other was a real windows machine).

Changed 11 years ago by tk

Attachment: bc_test.jpg added

IE7 vista - tk

Changed 11 years ago by tk

Attachment: bc_test2.jpg added

IE7 vista 2 - tk

comment:12 in reply to:  11 Changed 11 years ago by guest

Resolution: fixed
Status: closedreopened

Replying to bill:

Hmm, I see that it was failing for you but it's working for both me and sfoster now. I even tried on two machines (one was parallels on the mac, but the other was a real windows machine).

Yes, now it working for me also, on the last nightly build with IE7, something is influencing on this widget, may be .. the css as you proposed before. For sure the problem were on every company here, and ie7 browser I checked.

See this is the problem in this specific PR:

[1] I opened for Scroll on FF. [2] When you tested, the Scroll problem was mysteriously corrected but the IE7 crashing problem occurred. [3] When you tested the crashing, it also was mysteriously corrected, but AGAIN the

scrolling problem on FF reappear.

I will reopen for the last time this PR. I think that the scrolling problem is critical for everyone,I see this reopening as my microscopic contribution to the healthy of this widget.

See this scenario: I have a big tree inside the BorderContainer?, even if the container is defined with maximum height the tree is bigger than that, and you can not see the lasts items in the tree. Scrolling do not appear even if I played with every possible value in the css (On Split Container+Layout container every thing is OK, I can scroll and see the last items in the tree)

See the last gif I attached (was tested on XP, FF 2.0.0.11) Write me if I can help on anything. Again I will reopen for the last time, this issue.

Thanks

Eduardo

Changed 11 years ago by guest

Attachment: newAndLastFF2.gif added

see the container with "main panel with a link" -> No Vertical Scroll Bar

comment:13 Changed 11 years ago by bill

Owner: changed from Adam Peller to bill
Status: reopenednew

Yup, I see it, and I traced the cause to this code in dijit.css:

overflow: -moz-scrollbars-none;

No idea why that code is there. Removing it seems to fix this w/out any ill effects, so I'll do that.

comment:14 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

(In [12436]) Remove mysterious "overflow: -moz-scrollbars-none" setting for BorderContainer? panes. Not sure why that code was there (although I can see how overflow: hidden makes sense for the BorderContainer? itself, rather than it's panes), but it naturally causes scrollbars on the panes to not appear, even when they should. Fixes #5737.

comment:15 Changed 11 years ago by Adam Peller

I *think* this caused a regression in theme tester, where FF now shows empty scrollbars around the heading "Dijit Theme Test Page"

comment:16 in reply to:  15 Changed 11 years ago by guest

Replying to peller:

I *think* this caused a regression in theme tester, where FF now shows empty scrollbars around the heading "Dijit Theme Test Page"

Thanks !!!!!!!!!!!!!!!!!!!!! Bill and Peller, now I can use the BorderContainer? . I will test it when the nightly build is released, but it smell that this is the solution for the problem.

Eduardo

Note: See TracTickets for help on using tickets.