Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#573 closed defect (fixed)

SlideShow widget doesn’t loop when there are only two slides in Safari

Reported by: formm3@… Owned by: dylan
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: Slideshow Cc:
Blocked By: Blocking:

Description

If you want to loop through only two images using the Slideshow widget. Safari v1.3 and v2.0.1 will get to the second image and then stop. If you have more then two images it will loop fine.

Change History (5)

comment:1 Changed 13 years ago by alex

Milestone: 0.3release
Owner: changed from anonymous to alex
Status: newassigned

comment:2 Changed 13 years ago by alex

Milestone: 0.3release0.4
Owner: alex deleted
Status: assignednew

comment:3 Changed 13 years ago by dylan

Owner: set to dylan
Status: newassigned

fixed in [4978] and testcase added... basically the issue is that safari doesn't fire the onload event if the two images are just being swapped around, so I've added a param after the image name to prevent Safari from caching the image, if there are only two images and Safari is the rendering environment

comment:4 Changed 13 years ago by dylan

Resolution: fixed
Status: assignedclosed

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.