Opened 12 years ago

Closed 11 years ago

#5676 closed defect (fixed)

ContentPane: better detection about which widget to resize (in layout mode)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

This ticket is based on #5169. If a ContentPane has a single child (possibly loaded via an href), it can act like a proxy, and reflect size changes of itself to that single child. However, doesn't work so well if there are extraneous children, such as having a LayoutContainer and a dojo.data.store child too.

[12160] lets the developer specify when ContentPane? should act as a layout container, but that still doesn't solve the problem here. As per the TODO in that checkin it should be more intelligent about finding the widget to resize, probably by looking for a widget with a resize() method.

See also related bug #5638 (which I might close as a duplicate of this one).

Change History (4)

comment:1 Changed 12 years ago by bill

Owner: set to bill
Status: newassigned

comment:2 Changed 12 years ago by bill

Description: modified (diff)

comment:3 Changed 12 years ago by bill

Milestone: 1.11.2

comment:4 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [15039]) Fixes #5676 !strict: ContentPane?: better detection about which widget to resize (in layout mode). Basically, it ignores things in the child list like data stores. ContentPane? test seems to be hanging on IE7 unrelated to this change :-(

Note: See TracTickets for help on using tickets.