Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5673 closed defect (fixed)

AccordionContainer: pane can't contain independently sized layout widgets

Reported by: bill Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

See #5672 for details. Basically, if an accordion panel contains layout widgets which are independently sized, they will not initialize correctly.

Change History (10)

comment:1 Changed 12 years ago by alex

Milestone: 2.01.3

Milestone 2.0 deleted

comment:2 Changed 12 years ago by sos

I have come across this issue too. It is caused by the direct assigning of a height style to the AccordionPane?, rather than allowing it to naturally size according to its content.

This seems to be a result of the widget always trying to fit the headers of all the panes on screen at the same time - it shrinks the open pane's body to fit. This does not scale to more than 10 panes on an average resolution.

comment:3 Changed 12 years ago by bill

Umm, sounds like you should just use a <div> with a bunch of TitlePanes in it; AccordionContainer is not appropriate for all situations. But this ticket is about something else, unrelated to your comment.

comment:4 Changed 11 years ago by dante

Milestone: 1.31.4
Owner: set to dante
Status: newassigned

I am going to take a look at this as part of a proposed accordionContainter refactor to allow Layout Widgets as direct children, deprecating AccordionPane?.

comment:5 Changed 11 years ago by bill

Thanks Peter! Refactor mentioned above is ticket #6842.

comment:6 Changed 11 years ago by dante

Milestone: 1.41.3

comment:7 Changed 11 years ago by bill

Milestone: 1.31.4

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:8 Changed 11 years ago by bill

Milestone: 1.41.3
Owner: changed from dante to bill
Status: assignednew

comment:9 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

Fixed in [15962]: For TabContainer?, StackContainer?, and AccordionContainer?, render unselected panes offscreen rather than making them display:none. This allows the panes to contain multiple embedded layout widgets (as opposed to a single layout widget which is sized the same as the ContentPane?).

IE6 was problematic; had to hack the CSS to not using visibility:hidden, and to revert to display:none for doLayout=false mode).

Fixes #5672, #5673 !strict.

comment:10 Changed 11 years ago by bill

Also [15942]: Due to [15962], ContentPane? now needs to check if it's been hidden via the dijitHidden class. Refs #5672, #5673 !strict.

Note: See TracTickets for help on using tickets.