Opened 11 years ago

Closed 5 years ago

#5653 closed defect (wontfix)

InlineEditBox: blur of editor switches to view mode

Reported by: bill Owned by:
Priority: low Milestone: 2.0
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

See test_InlineEditBox.html and click on the currency amount. On FF the value will change from $2,000.00 to 2000.00 for editing. However, if you click a blank area of the screen, the value will revert to $2,000.00, even though you are still editing the value.

Clearly this is due to how TextBox works (showing the edit value only when the <input> has focus, but it's not ideal for this case.

Not sure how to address it.

Change History (5)

comment:1 Changed 11 years ago by bill

Milestone: 2.0

comment:2 Changed 11 years ago by Douglas Hays

Maybe this is just a little quirk and should not be fixed. Technically you're not editing the value anymore until you refocus the edit widget and then it changes back to edit mode.

comment:3 Changed 6 years ago by bill

Priority: highlow

comment:4 Changed 5 years ago by sunxcint

This is due to how CurrencyTextBox?, which was taken as the editor of the InlineEditBox? you mentioned above, works. So I think this is not a bug actually.

comment:5 Changed 5 years ago by bill

Description: modified (diff)
Resolution: wontfix
Status: newclosed

I'd call it a bug, since the behavior is both unexpected and unwanted by are users. But as Doug said, this is probably not worth fixing, so I'm closing the ticket as wontfix.

Note: See TracTickets for help on using tickets.