Opened 12 years ago

Closed 11 years ago

#5642 closed defect (fixed)

Grid: ItemFileReadStore, after sorting, edit data in table disappears

Reported by: guest Owned by: sorvell
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.0
Keywords: grid itemfilereadstore model sort Cc: frank.fortson@…
Blocked By: Blocking:

Description (last modified by Bryan Forbes)

frankf: The Jan 15 Ticket 5555 fixed Ticket 5275 (incorrect model data resulting from a sort on an edited *write* store), but now the same test file (and steps to reproduce) shows that edits in the model are not passed through to the *read* store, which, when restored via sort (from the store), erases the model changes. In other words, edits in the model do not pass through to the store, when a read store is used. This may be by design??

To duplicate, do the same test in Ticket 5275, but notice that after a sort, the left Grid (read store) no longer shows the changes.

IIRC, the problem will be in model.js, datumChange:, where it writes the changes to the store *if* the store supports "write", e.g., if(this._canWrite){...

Again, this may be by design, not sure. If so, should the grid reject the user's model changes for a read store?

Change History (3)

comment:1 Changed 12 years ago by Frank Fortson

Since the intent is to not permit writes to the store for "read" stores, and that is the way the Grid works, the question is should the grid widgets (editors, .Bool, etc.) and/or grid.model.setDatum be permitted to change the model and the UI, indicating to the user that the "data" has been changed, when it has not been changed in the store? If they are counting on the changes they make being persistent, they won't last past a sort.

comment:2 Changed 12 years ago by dylan

Milestone: 1.2

comment:3 Changed 11 years ago by Bryan Forbes

Description: modified (diff)
Resolution: fixed
Status: newclosed

Read-only stores don't support grid editing anymore.

Note: See TracTickets for help on using tickets.