Opened 11 years ago

Closed 11 years ago

#5632 closed defect (wontfix)

FF2: Editor stealing events from document

Reported by: Adam Peller Owned by: liucougar
Priority: high Milestone: 1.1
Component: Editor Version: 1.0
Keywords: Cc: mpawlow@…
Blocked By: Blocking:

Description

See the test case in #5099 (dojo-editor-test.html)

Click on "Rich Text". The rich text editor now appears properly. Then try to click on the HTML button -- you can't. The events seem to be grabbed by the editor.

This only seems to happen in FF2, not FF3 or IE.

Change History (4)

comment:1 Changed 11 years ago by liucougar

the problem is that the default height of the editing area is 300px, but the container div of the editor is only 150px high (specified in .rich-text-editor-area), and the remaining 150px of the editing area iframe is somehow covering up the following content (in this case, two buttons) and the iframe is transparent in FF2

if you remove the height rule in .rich-text-editor-area, and instead set height:150px when constructing the dijit.Editor, it should be fine

let me know how it works for you

comment:2 Changed 11 years ago by guest

Setting the height on the dijit.Editor directly using it's constructor worked for the reproducible test case I provided.

This afternoon I'm going to deploy the actual build including the fix in my production environment to determine whether it works there as well.

Thanks for looking into this.

comment:3 Changed 11 years ago by guest

The fix worked in my production environment. Feel free to resolve this bug.

comment:4 Changed 11 years ago by Adam Peller

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.