Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#5620 closed defect (fixed)

dojox.widget.Wizard widget buttons trapping click

Reported by: dante Owned by: Douglas Hays
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 1.0
Keywords: Cc: simonjb
Blocked By: Blocking:

Description

as of 01-18-2008, dojox.widget.Wizard buttons do not work.

http://archive.dojotoolkit.org/dojo-2008-01-18/dojotoolkit/dojox/widget/tests/test_Wizard.html

the last working nightly: http://archive.dojotoolkit.org/dojo-2008-01-17/dojotoolkit/dojox/widget/tests/test_Wizard.html

the line removing:

mapNode[attr] = value; //FF2 won't set readOnly et al with node.setAttribute

for dojo.attr() in [12067] is the cause of the regression.

Change History (4)

comment:1 Changed 12 years ago by dante

Component: GeneralDijit
Owner: changed from anonymous to Douglas Hays
Summary: [dojox] Wizard widget buttons trapping clickdojox.widget.Wizard widget buttons trapping click

comment:2 Changed 12 years ago by Douglas Hays

Cc: simonjb added

dojo.attr can't use setAttribute with disabled or readonly on FF

comment:3 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [12090]) Fixes #5620 !strict. Added support to dojo.attr for boolean attributes on Firefox.

comment:4 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.