Opened 11 years ago

Closed 11 years ago

#5600 closed defect (fixed)

editor: buttons in editor toolbar are in the tab order and should not be

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.1
Component: Accessibility Version: 1.0
Keywords: a11y Cc: Becky Gibson, Douglas Hays
Blocked By: Blocking:

Description

The buttons in the editor toolbar are in the tab order and should not be. Once focus is on a button in the toolbar the arrow keys work to move focus from button to button using the keyboard. This works correctly in the editor toolbar. However, pressing tab also moves focus from toolbar button to toolbar button - this should not work. Only the arrow keys should work to move focus within the toolbar. When focus is in the editor toolbar, pressing tab should move focus into the editor.

The standard toolbar (test_toolbar.html) works correctly. This change in behavior for the editor toolbar buttons is a regression from 1.0.2.

Change History (6)

comment:1 Changed 11 years ago by Becky Gibson

This broke on the nightly build dated 12/20/2007

comment:2 Changed 11 years ago by Becky Gibson

Was caused by the change to setAttribute() in _FormWidget.js. Shows up in the editor toolbar because it enables and disables buttons in the toolbar. Probably need to have a specific setAttribute() for buttons and if in a toolbar do not modify the tabindex value

comment:3 Changed 11 years ago by Becky Gibson

Cc: Douglas Hays added
Component: EditorAccessibility
Owner: changed from liucougar to Becky Gibson

comment:4 Changed 11 years ago by Becky Gibson

Status: newassigned

comment:5 Changed 11 years ago by Becky Gibson

Milestone: 1.0.31.1

realized that this is not broken in the 1.0.2 version so doesn't need to be fixed for 1.0.3 ;-)

comment:6 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: assignedclosed

(In [12148]) fixes #5600 Just needed to add tabIndex=-1 into the button parameters in _initButton function.

Note: See TracTickets for help on using tickets.