Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5590 closed defect (fixed)

Wrong focus after row adding in grid when moving with with cursor keys.

Reported by: guest Owned by: benschell
Priority: high Milestone:
Component: DojoX Grid Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi!

When you select a row with the mouse, then move the focus with the direction keys (cursor keys) and then add a row (we use a button outside the grid for this), the first cell in this new row is set to edit mode. So far, so good. Then if you press the tab key, the focus goes to the next cell in the row you selected first with the mouse instead the next in the new row.

Thanks and best regards!!

Attachments (2)

5590.patch (420 bytes) - added by benschell 12 years ago.
5590.2.patch (413 bytes) - added by Jared Jurkiewicz 12 years ago.
Minor stylistic correction, removed whitespace.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by bill

Component: GeneralDojoX Grid
Owner: changed from anonymous to sorvell

comment:2 Changed 12 years ago by benschell

Owner: changed from sorvell to benschell

I'm taking a stab at a whole bunch of Grid bugs. Re-assigning.

comment:3 Changed 12 years ago by benschell

Status: newassigned

It actually doesn't matter if you use the arrow keys or not. The problem is that the focus is not moved to the first editable cell, or the first cell if no editors are allowed. Patch attached which changes the focus to the added row.

Changed 12 years ago by benschell

Attachment: 5590.patch added

Changed 12 years ago by Jared Jurkiewicz

Attachment: 5590.2.patch added

Minor stylistic correction, removed whitespace.

comment:4 Changed 12 years ago by Jared Jurkiewicz

Resolution: fixed
Status: assignedclosed

(In [12517]) Committing in focus fix from Ben Schell. fixes #5590

comment:5 Changed 12 years ago by Jared Jurkiewicz

Quick tested on:

IE 6

Firefox 2.0.0.12

Safari B3

Note: See TracTickets for help on using tickets.