Opened 11 years ago

Closed 11 years ago

#5586 closed defect (fixed)

dropdownButton with menu: extra events with no role in FF3

Reported by: Becky Gibson Owned by: simonjb
Priority: high Milestone: 1.1
Component: Accessibility Version: 1.0
Keywords: FF3 a11y Cc:
Blocked By: Blocking:

Description

When viewing events via AccEvent? the Edit Button in tests/form/test_Button.html shows several events in FF3 with no role information. This looks correct in FF2 but need to determine if this is solely a FF3 issue or if changes are needed within dropDownbutton as well. Email sent to Minefield a11y developer for clarification. Here is the event log when focus is on edit button and press down arrow (or enter key).

FF2 events:

OBJ_FOCUS	 Name="Edit!" Role=push button State=focused,focusable,has popup
OBJ_FOCUS	 Name="Cut" Role=menu item State=focused
OBJ_SHOW	 Name="" Role=popup menu State=normal

Minefield (build dated 01/14/08):

OBJ_FOCUS	 Name="Edit!" Role=push button State=focused,focusable,has popup
OBJ_FOCUS	 Name="Cut" Role=menu item State=focused,focusable
OBJ_SHOW	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=floating
OBJ_HIDE	 Name=none [null] Role="tr" [ BUG? State/Role should not be a string ] State=focusable
OBJ_HIDE	 Name=none [null] Role="tr" [ BUG? State/Role should not be a string ] State=focusable
OBJ_HIDE	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_HIDE	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_HIDE	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_HIDE	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_HIDE	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_SHOW	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=floating

Change History (7)

comment:1 Changed 11 years ago by Becky Gibson

(In [12029]) refs #5586. Need to add focusNode to td acting as menuitem. Otherwise extra tabindex gets added into menu by KeyNavContainer?. !strict

comment:2 Changed 11 years ago by Becky Gibson

comment:3 Changed 11 years ago by Becky Gibson

Owner: changed from Becky Gibson to simonjb

seems to be a duplicate of #4616 - transferring to Simon since he is looking at #4616

comment:4 Changed 11 years ago by simonjb

Status: newassigned

comment:5 Changed 11 years ago by simonjb

Here's what I am getting today, after #4616 has been closed and role="presentation" has been added to some other templates (#5702):

OBJ_FOCUS	 Name="Edit!" Role=menu button State=focused,focusable,has popup
(unknown)	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
(unknown)	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_FOCUS	 Name="Cut" Role=menu item State=focused,focusable
(unknown)	 Name="Cut" Role=menu item State=focused,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_SHOW	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=floating
SYS_MENUPOPUPSTART	 Name="" Role=popup menu State=read only,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_SHOW	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=floating

Adding role="presentation" to the dijit.popup.open() wrapper:

OBJ_FOCUS	 Name="Edit!" Role=menu button State=focused,focusable,has popup
(unknown)	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
(unknown)	 Name=none [null] Role="div" [ BUG? State/Role should not be a string ] State=normal
OBJ_FOCUS	 Name="Cut" Role=menu item State=focused,focusable
(unknown)	 Name="Cut" Role=menu item State=focused,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_SHOW	 Name="" Role=popup menu State=read only,focusable
SYS_MENUPOPUPSTART	 Name="" Role=popup menu State=read only,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_SHOW	 Name="" Role=popup menu State=read only,focusable

The remaining Role="div" events are on the div in test_Button.html containing the buttons. If I add role="presentation" to that div, then the events move to the document:

OBJ_FOCUS	 Name="Edit!" Role=menu button State=focused,focusable,has popup
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_FOCUS	 Name="Cut" Role=menu item State=focused,focusable
(unknown)	 Name="Cut" Role=menu item State=focused,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_SHOW	 Name="" Role=popup menu State=read only,focusable
SYS_MENUPOPUPSTART	 Name="" Role=popup menu State=read only,focusable
(unknown)	 Name="Dojo Button Widget Test" Role=document State=read only,focusable
OBJ_SHOW	 Name="" Role=popup menu State=read only,focusable

comment:6 Changed 11 years ago by simonjb

(In [12468]) Added role="presentation" to the dijit.popup.open() wrapper div; refs #5586

comment:7 Changed 11 years ago by simonjb

Resolution: fixed
Status: assignedclosed

With the change to dijit.popup.open I think we are done.

Note: See TracTickets for help on using tickets.