Opened 12 years ago

Closed 11 years ago

#5582 closed defect (worksforme)

duplicate attachPoints in dojox.Grid

Reported by: tk Owned by: sorvell
Priority: high Milestone: 1.1
Component: DojoX Grid Version: 1.0
Keywords: grid HeaderNode Cc:
Blocked By: Blocking:

Description

if you goto, http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/grid/tests/test_grid.html

then do var grid = dijit.byId('grid'); grid.headerNode; grid.headerNode.firstChild; in Firebug you will see that firstChild has the same attachPoint assigned to it...

while this doesnt cause any known bugs, it could cause difficulty in people achieving desired results if they are trying to attach to the wrong one.

Change History (6)

comment:1 Changed 12 years ago by dylan

Milestone: 1.1

comment:2 Changed 11 years ago by sorvell

Resolution: fixed
Status: newclosed

(In [12849]) !strict fixes #5582 To avoid confusion, the duplicate attach point name "headerNode" shared by view and grid was changed. Each view now has a headerNode and the grid itself has a viewsHeaderNode.

comment:3 Changed 11 years ago by guest

Resolution: fixed
Status: closedreopened

This checkin breaks Grids with the following error:

dojo.addOnLoad callback failed: TypeError?: this.viewsHeaderNode has no properties

TypeError?: this.viewsHeaderNode has no properties message=this.viewsHeaderNode has no properties

loader.js (line 147)

comment:4 Changed 11 years ago by sorvell

Cannot reproduce this problem. Could this be a caching problem? The grid's template file was changed.

Can you please post a test case if it's not resolved by clearing cache? Thanks.

comment:5 Changed 11 years ago by guest

Doh! Problem went away after clearing cache. Sorry for the inconvenience.

comment:6 Changed 11 years ago by sorvell

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.