Opened 11 years ago

Closed 11 years ago

#5526 closed defect (fixed)

slider values are not available in MSAA in FF3

Reported by: simonjb Owned by: simonjb
Priority: high Milestone: 1.1
Component: Accessibility Version: 1.0
Keywords: Cc: Becky Gibson
Blocked By: Blocking:

Description

I'm not sure if this is a Dojo bug or a Firefox one. I tested Minefield nightly 3.0b3pre (2008-01-07)

To reproduce:

  • open the Microsoft Inspect tool
  • open dijit/tests/form/test_Slider.html
  • tab to the first slider

Expect:

  • Value: 10.0 %

Actual

  • Value: none [false]

Change History (4)

comment:1 Changed 11 years ago by simonjb

Status: newassigned

Scott reported that the slider has some sections that should be marked as "presentation" -- related? (should the image be marked as "presentation"?)

comment:2 Changed 11 years ago by simonjb

Minefield is able to successfully read the value from http://www.mozilla.org/access/dhtml/simple-slider

comment:3 Changed 11 years ago by simonjb

This bug is caused by a behaviour in FF3: values of sliders are not available via MSAA if they have an onclick handler. I've filed a bug against Mozilla: https://bugzilla.mozilla.org/show_bug.cgi?id=413376

The Dijit slider attaches an onclick handler in the slider templates:

dojoAttachEvent="onkeypress:_onKeyPress,onclick:_onHandleClick"

The slider _onHandlerClick() method sets focus to the handle. While I think this is a bug in Mozilla, I'm not sure that we need this click handler?

comment:4 Changed 11 years ago by simonjb

Resolution: fixed
Status: assignedclosed

Bug fixed in Mozilla

Note: See TracTickets for help on using tickets.