Opened 11 years ago

Closed 11 years ago

#5516 closed defect (wontfix)

Major and minor gridline selection is not mutually exclusive

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone:
Component: Charting Version: 1.0
Keywords: chart grid Cc: gresham@…
Blocked By: Blocking:

Description

When plotting a grid on the chart, it is not possible to select only minor or only major gridlines.

The problem lies with the code (dojox/charting/plot2d/Grid.js lines 53 - 106) which will plot every line on the minor scale, thus is inclusive of the major scale should they fall upon the same point.

What does happen when including both major and minor gridlines, is that the major lines are slightly stronger in appearance so the current functionality does appear to be intentional.

It would be nice to change the object interface to hide more of the internals of the charting system as the options we set really expose the underlying logic a bit too much. However given that would break existing usage of the api, perhaps (yet another flag) would be in order onlyMinor: {false|true} such that the algorithm can select the appropriate course of action whilst not changing the way the code works today.

gresham at mediavisual dot com

Change History (1)

comment:1 Changed 11 years ago by Eugene Lazutkin

Resolution: wontfix
Status: newclosed

This is the intended behavior. Desirable effects can be achieved by the axis/grid styling.

Note: See TracTickets for help on using tickets.