Opened 11 years ago

Closed 11 years ago

#5515 closed defect (wontfix)

Axis drawing order causes overwrite of chart symbols

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.1
Component: Charting Version: 1.0
Keywords: axis chart Cc: gresham@…
Blocked By: Blocking:

Description

dojox/charting/Chart2D.js In the render method between lines 203 to 206 there is a problem that the chart components are held in a stack and rendered in sequence, this is followed by the rendering of the axes via a separate rendering loop.

The problem is that the axis will draw above the symbols already rendered in the chart area should those symbols be on the first value of either axis.

A possible solution is to get the axes into the stack in the correct place such that rendering always happens correctly.

gresham at mediavisual dot com

Change History (3)

comment:1 Changed 11 years ago by guest

#5228 may also be related to this problem

gresham at mediavisual dot com

comment:2 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.1
Status: newassigned

Actually that was the intended behavior. I'll keep this ticket open to see if it warrants the change.

comment:3 Changed 11 years ago by Eugene Lazutkin

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.