Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5482 closed defect (invalid)

Dojo Book: IE fails on several pages "Internet Explorer cannot display the page"

Reported by: Frank Fortson Owned by: criecke
Priority: high Milestone:
Component: book Version: 1.0
Keywords: documentation ie cannot display page Cc: frank.fortson@…
Blocked By: Blocking:

Description

See Forum Discussion.

On one (or several) demo pages in the Dojo Book, a script line is included as the last line inside a div to be explicitly parsed. The script line, inside the div, calls for parsing the same div that includes that script line.

Firefox handles this, but IE doesn't.

Moving the script line (parser) just outside the div to be parsed works for both FF and IE.

Attachments (1)

ieprob.html (1.2 KB) - added by guest 12 years ago.
Documentation: IE cannot display certain demo pages

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by guest

Attachment: ieprob.html added

Documentation: IE cannot display certain demo pages

comment:1 Changed 12 years ago by Neil Roberts

Component: Documentationbook
Owner: changed from Neil Roberts to criecke

comment:2 Changed 12 years ago by Adam Peller

Owner: changed from criecke to bill

Bill, should the script tag work inside the div? If not, let's document it (wontfix) and just fix the book -- we'll address that through book comments on a thread somewhere rather than in trac.

comment:3 Changed 12 years ago by bill

Technically I don't think you should be have <script> tags inside <body> (rather than <head>) at all, but as a practical matter maybe it's OK except for the case mentioned in this ticket. I'd consider this a bug in the book's examples, not in dojo or IE.

comment:4 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

at least in the editor example, the culprit was apparently the fact that the call to parse was not in an addOnLoad, triggering a timing problem. It's established that this should have occurred after onload, so that much isn't a bug.

comment:5 Changed 11 years ago by Frank Fortson

Reporter: changed from guest to Frank Fortson
Resolution: invalid
Status: closedreopened

Since this problem with the "book" continues to be mentioned in the forums (people using IE can't view pages in the Book of Dojo that have this problem--looks bad for Dojo), can this be assigned to the book maintainer?

Latest posting about it: forum

From some testing I did, I believe the fix is to wrap the offending script function in a dojo.addOnLoad.

<script>dojo.parser.parse(dojo.byId("code1"));</script>

like this:

<script>
  dojo.addOnLoad(function(){dojo.parser.parse(dojo.byId("code1"));});
</script>

This was probably closed due to the discussion turning to whether there was a defect in Dojo or not. It is really a mis-coding in the Book of some of the examples, most of which use a div with an id like "code1", "code2", etc. Then loads dojo and the requires nearby and within or just after the code1 div, call the parser on that same code1 block.

comment:6 Changed 11 years ago by Adam Peller

Owner: changed from bill to criecke
Status: reopenednew

I made the change to the Dialog page. I'm cc'ing Craig so he's aware of the issue, as it's probably necessary to do a scan of the book for this sort of thing, but I don't think Craig uses trac much so this probably is not the way to resolve the issue, and we have established that it's not a bug in the toolkit. Posting comments directly to the pages is the way to go, and ping someone with book access if it doesn't get fixed (or if you've sent in a CLA and you want edit access, maybe we can add more people to the list?) We do need to get all of these instances fixed, though.

comment:7 Changed 11 years ago by Adam Peller

Resolution: invalid
Status: newclosed

comment:8 Changed 11 years ago by Frank Fortson

Thanks. I believe a comment has been added to at least one page, not positive. I'll be glad to go through and find/make the changes, if needed. Email is in the cc field.

Note: See TracTickets for help on using tickets.